summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2019-01-06 08:36:37 +0100
committerFernandez Ludovic2019-01-06 08:36:37 +0100
commit87dd92277fcdd847577da9665baa286b54bd15c9 (patch)
tree6782a1c90019bf93c922862cff5db1287ffce6c5
parent10c8923d1abc0a140248dd8f19bbae617ee24943 (diff)
downloadaur-87dd92277fcdd847577da9665baa286b54bd15c9.tar.gz
refactor: factorize.
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 556ca5e5b5c0..5f5663cd99b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,22 +11,18 @@ license=('APACHE')
provides=("${pkgname}")
conflicts=("${pkgname}" "${pkgname}-git")
-depends=(
- 'git'
-)
-
+depends=('git')
makedepends=()
source=("https://github.com/ldez/prm/releases/download/${pkgver}/prm_linux-amd64"
"https://raw.githubusercontent.com/ldez/prm/master/LICENSE")
-
sha256sums=("912eeede21e18e1dd7e31179f107cd3eee969ff52f7023a7cb4c5bc168892952"
"4cc1b9526ac9a5f81b49e804ddeb134b3a70262f6d760c9fb2fb98fb1d6603ba")
package() {
# Bin
- rm -f "${pkgdir}"/usr/bin/prm
- install -Dm755 "${srcdir}/prm_linux-amd64" "${pkgdir}/usr/bin/prm"
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}_linux-amd64" "${pkgdir}/usr/bin/${pkgname}"
# License
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"