summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2019-01-05 05:38:14 +0100
committerFernandez Ludovic2019-01-05 05:38:14 +0100
commitb4d79b4cc7ff51211b0529948a2fd122b8340892 (patch)
tree184fb26a44c87a1b6715265e975b7aa89dfd8a4f
downloadaur-b4d79b4cc7ff51211b0529948a2fd122b8340892.tar.gz
feat: v2.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD33
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fe4b833fa05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = prm
+ pkgdesc = Pull Request Manager for Maintainers
+ pkgver = v2.3.0
+ pkgrel = 1
+ url = https://github.com/ldez/prm
+ arch = x86_64
+ license = APACHE
+ depends = git
+ provides = prm
+ conflicts = prm
+ conflicts = prm-git
+ source = https://github.com/ldez/prm/releases/download/v2.3.0/prm_linux-amd64
+ source = https://raw.githubusercontent.com/ldez/prm/master/LICENSE
+ sha256sums = 912eeede21e18e1dd7e31179f107cd3eee969ff52f7023a7cb4c5bc168892952
+ sha256sums = 4cc1b9526ac9a5f81b49e804ddeb134b3a70262f6d760c9fb2fb98fb1d6603ba
+
+pkgname = prm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbe2c62ea8e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+LICENSE
+prm_linux-*
+src/
+pkg/
+
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73ffeda5688f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fernandez Ludovic <lfernandez.dev@gmail.com>
+
+pkgname='prm'
+pkgver=v2.3.0
+pkgrel=1
+pkgdesc='Pull Request Manager for Maintainers'
+url='https://github.com/ldez/prm'
+arch=('x86_64')
+license=('APACHE')
+
+provides=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-git")
+
+depends=(
+ 'git'
+)
+
+makedepends=()
+
+source=("https://github.com/ldez/prm/releases/download/${pkgver}/prm_linux-amd64"
+ "https://raw.githubusercontent.com/ldez/prm/master/LICENSE")
+
+sha256sums=("912eeede21e18e1dd7e31179f107cd3eee969ff52f7023a7cb4c5bc168892952"
+ "4cc1b9526ac9a5f81b49e804ddeb134b3a70262f6d760c9fb2fb98fb1d6603ba")
+
+package() {
+ # Bin
+ rm -f "${pkgdir}"/usr/bin/prm
+ install -Dm755 "${srcdir}/prm_linux-amd64" "${pkgdir}/usr/bin/prm"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}