summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2019-01-06 12:37:06 +0100
committerFernandez Ludovic2019-01-06 12:37:06 +0100
commite82f1cb1b7d691ae297fa8e439595e864a28b9a0 (patch)
tree3da7afb3991d15132db78791be7716094d09bfb8
parent87dd92277fcdd847577da9665baa286b54bd15c9 (diff)
downloadaur-e82f1cb1b7d691ae297fa8e439595e864a28b9a0.tar.gz
feat: v2.4.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fe4b833fa05..cc879e2b1b76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,25 @@
pkgbase = prm
pkgdesc = Pull Request Manager for Maintainers
- pkgver = v2.3.0
+ pkgver = v2.4.0
pkgrel = 1
url = https://github.com/ldez/prm
arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
license = APACHE
depends = git
provides = prm
conflicts = prm
conflicts = prm-git
- source = https://github.com/ldez/prm/releases/download/v2.3.0/prm_linux-amd64
- source = https://raw.githubusercontent.com/ldez/prm/master/LICENSE
- sha256sums = 912eeede21e18e1dd7e31179f107cd3eee969ff52f7023a7cb4c5bc168892952
- sha256sums = 4cc1b9526ac9a5f81b49e804ddeb134b3a70262f6d760c9fb2fb98fb1d6603ba
+ source_x86_64 = https://github.com/ldez/prm/releases/download/v2.4.0/prm_v2.4.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 043ad137dd495358e9f647597ebe7a608a3ae2d7f25771e10480771c69cd8135
+ source_i686 = https://github.com/ldez/prm/releases/download/v2.4.0/prm_v2.4.0_linux_386.tar.gz
+ sha256sums_i686 = 5b5b809b11cdd9b372514fd016674a029fcfb451af0048db247551608932398f
+ source_armv7h = https://github.com/ldez/prm/releases/download/v2.4.0/prm_v2.4.0_linux_armv7.tar.gz
+ sha256sums_armv7h = 42f0486f2f617363f0c3e3a8588953116a76ccec471409fe93e3431a9d3ebc0f
+ source_aarch64 = https://github.com/ldez/prm/releases/download/v2.4.0/prm_v2.4.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = fb16b3ed1a720695eb30e65178348855a862e51eb0f96b7552a62bc474a2621e
pkgname = prm
diff --git a/PKGBUILD b/PKGBUILD
index 5f5663cd99b7..2d46326a326f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Fernandez Ludovic <lfernandez dot dev at gmail dot com>
pkgname='prm'
-pkgver=v2.3.0
+pkgver=v2.4.0
pkgrel=1
pkgdesc='Pull Request Manager for Maintainers'
url='https://github.com/ldez/prm'
-arch=('x86_64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
license=('APACHE')
provides=("${pkgname}")
@@ -14,16 +14,25 @@ conflicts=("${pkgname}" "${pkgname}-git")
depends=('git')
makedepends=()
-source=("https://github.com/ldez/prm/releases/download/${pkgver}/prm_linux-amd64"
- "https://raw.githubusercontent.com/ldez/prm/master/LICENSE")
-sha256sums=("912eeede21e18e1dd7e31179f107cd3eee969ff52f7023a7cb4c5bc168892952"
- "4cc1b9526ac9a5f81b49e804ddeb134b3a70262f6d760c9fb2fb98fb1d6603ba")
+_source="${url}/releases/download/${pkgver}/${pkgname}_${pkgver}_linux"
+
+source_x86_64=("${_source}_amd64.tar.gz")
+sha256sums_x86_64=('043ad137dd495358e9f647597ebe7a608a3ae2d7f25771e10480771c69cd8135')
+
+source_i686=("${_source}_386.tar.gz")
+sha256sums_i686=('5b5b809b11cdd9b372514fd016674a029fcfb451af0048db247551608932398f')
+
+source_armv7h=("${_source}_armv7.tar.gz")
+sha256sums_armv7h=('42f0486f2f617363f0c3e3a8588953116a76ccec471409fe93e3431a9d3ebc0f')
+
+source_aarch64=("${_source}_arm64.tar.gz")
+sha256sums_aarch64=('fb16b3ed1a720695eb30e65178348855a862e51eb0f96b7552a62bc474a2621e')
package() {
# Bin
rm -f "${pkgdir}/usr/bin/${pkgname}"
- install -Dm755 "${srcdir}/${pkgname}_linux-amd64" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# License
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}