summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorscan2018-09-19 02:18:47 -0300
committerscan2018-09-19 02:18:47 -0300
commit3360bed25596e1314cd52e9e816fa0d02bcdd5d6 (patch)
treeb891c6f05d917d3019901af28532b5f9c707a0ae
downloadaur-3360bed25596e1314cd52e9e816fa0d02bcdd5d6.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72373aa60d63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Sep 19 05:18:15 UTC 2018
+pkgbase = pro-dark-gtk-theme-git
+ pkgdesc = Pro Dark GTK Theme GNOME 3.20+
+ pkgver = r16.0c896ac
+ pkgrel = 1
+ url = https://github.com/paullinuxthemer/Pro-Dark-GTK
+ arch = any
+ license = GPL
+ makedepends = git
+ optdepends = gnome-tweak-tool: A tool to customize advanced GNOME 3 options.
+ source = pro-dark-gtk-theme::git+https://github.com/paullinuxthemer/Pro-Dark-GTK
+ sha256sums = SKIP
+
+pkgname = pro-dark-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50eb79bee2d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: scan
+
+pkgname=pro-dark-gtk-theme-git
+pkgver=r16.0c896ac
+pkgrel=1
+pkgdesc="Pro Dark GTK Theme GNOME 3.20+"
+arch=("any")
+url="https://github.com/paullinuxthemer/Pro-Dark-GTK"
+license=("GPL")
+makedepends=("git")
+optdepends=("gnome-tweak-tool: A tool to customize advanced GNOME 3 options.")
+source=("pro-dark-gtk-theme::git+https://github.com/paullinuxthemer/Pro-Dark-GTK")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd pro-dark-gtk-theme
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/themes
+ cp -r pro-dark-gtk-theme $pkgdir/usr/share/themes/Pro-Dark-GTK
+ find ${pkgdir} -type f -exec chmod 644 {} \;
+ find ${pkgdir} -type d -exec chmod 755 {} \;
+}