summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbhimanyu Sharma2023-02-19 12:45:26 +0000
committerAbhimanyu Sharma2023-02-19 12:45:26 +0000
commitc5b0d336d7cb8f22744324c0c70c3d337e88751d (patch)
tree2834a9e61b656f5f6314e14e08d2ea23d8c4c54d
parent92a222f299132823c5e88a3da3fbe2a14288488c (diff)
downloadaur-c5b0d336d7cb8f22744324c0c70c3d337e88751d.tar.gz
Update to v0.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6df3efc4705a..ee5de959b8d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,14 @@ pkgbase = probe-bin
license = MIT
conflicts = probe
provides = probe
+ arch = aarch64
+ source_aarch64 = https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_arm64.tar.gz
+ sha256sums_aarch64 = 83be588ed030aa9e69da3263c7706205a60d0c634dd0ddffab34d87a112c5059
+ arch = i686
+ source_i686 = https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_386.tar.gz
+ sha256sums_i686 = 4c96ff496a044dd5210eae1a62bc6784af8ba11d2ea76bf9bb465d9d22f5a2e9
arch = x86_64
source_x86_64 = https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_amd64.tar.gz
- sha256sums_x86_64 = fc5189759187e1b090cdac98940fc3ec6ed39e396d0127c248035b003897897b
+ sha256sums_x86_64 = b78256d1636dd06d0d1b64475d7eecb658a5fdf72fd6f7ebbf1e85f703d55fd0
pkgname = probe-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8651efe04a5d..a60f09346d01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,19 @@ pkgver=0.0.1
pkgrel=1
pkgdesc='YAML + JQ Based End-To-End API Testing.'
url='https://github.com/abhimanyu003/probe'
-arch=('x86_64')
+arch=('aarch64' 'i686' 'x86_64')
license=('MIT')
provides=('probe')
conflicts=('probe')
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_arm64.tar.gz")
+sha256sums_aarch64=('83be588ed030aa9e69da3263c7706205a60d0c634dd0ddffab34d87a112c5059')
+
+source_i686=("${pkgname}_${pkgver}_i686.tar.gz::https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_386.tar.gz")
+sha256sums_i686=('4c96ff496a044dd5210eae1a62bc6784af8ba11d2ea76bf9bb465d9d22f5a2e9')
+
source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/abhimanyu003/probe/releases/download/v0.0.1/probe_0.0.1_linux_amd64.tar.gz")
-sha256sums_x86_64=('fc5189759187e1b090cdac98940fc3ec6ed39e396d0127c248035b003897897b')
+sha256sums_x86_64=('b78256d1636dd06d0d1b64475d7eecb658a5fdf72fd6f7ebbf1e85f703d55fd0')
package() {
install -Dm755 "./probe" "${pkgdir}/usr/bin/probe"