summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilienLIX2015-09-04 20:47:07 +0200
committerMaximilienLIX2015-09-04 20:47:07 +0200
commit9de3c92db1095186de4caa97b542d894f85cf9b3 (patch)
treee7b23ab577d542b903e6d6f0a8123e4acc16847a
downloadaur-9de3c92db1095186de4caa97b542d894f85cf9b3.tar.gz
Say hello to arch
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d32afe8598cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = probuild-git
+ pkgdesc = An amelioration of GCC compiler which allow to compile a program without links in the command !
+ pkgver = r119.dd9d243
+ pkgrel = 1
+ url = https://gitlab.com/MaximilienLIX/probuild
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = gcc
+ depends = bash
+ source = git+https://gitlab.com/MaximilienLIX/probuild.git
+ md5sums = SKIP
+
+pkgname = probuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79eaa23ffaaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maximilien Di Dio <mrgamerlix@gmail.com>
+
+pkgname=probuild-git
+_pkgname_simple=probuild
+pkgver=r119.dd9d243
+pkgrel=1
+pkgdesc="An amelioration of GCC compiler which allow to compile a program without links in the command !"
+arch=('any')
+url="https://gitlab.com/MaximilienLIX/probuild"
+license=('LGPL3')
+depends=('gcc' 'bash')
+
+makedepends=('git')
+source=("git+https://gitlab.com/MaximilienLIX/probuild.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname_simple"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname_simple/LINUX"
+ make
+}
+
+package() {
+ cd "$_pkgname_simple/LINUX"
+ install -d "$pkgdir/usr/bin/"
+ install -d "$pkgdir/usr/share/man/man1/"
+ install -m755 "$srcdir/$_pkgname_simple/LINUX/bin/probuild" "$pkgdir/usr/bin"
+ install -m644 "$srcdir/$_pkgname_simple/LINUX/doc/probuild.gz" "$pkgdir/usr/share/man/man1/"
+}