summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2021-07-17 19:52:20 +0200
committerTorben2021-07-17 19:52:20 +0200
commit39e30c25e7734bcfa66f53e67cabe4c58c702a89 (patch)
tree35e3e8973c7b30ba129246e662844b49f5c4cf32
parent84d18e560b108a2936a664cb60c0cb6d2c758d6e (diff)
downloadaur-39e30c25e7734bcfa66f53e67cabe4c58c702a89.tar.gz
Use official versioning scheme for VCS packages; Update .SRCINFO
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc3323f13507..f3c57810db3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = processing4-git
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = r1.16863c8
+ pkgver = 4.0a6.r2.ga1122aa67
pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3e72e945965b..7a8fc3680940 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4-git
-pkgver=r1.16863c8
+pkgver=4.0a6.r2.ga1122aa67
pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
@@ -20,14 +20,16 @@ sha256sums=('fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+
+ git describe --long | sed 's/^processing-[^-]\+-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
# The size of a full clone is more than 1GB, so we just make a shallow clone
+ # Fetching 1000 commits is hopefully enough to find the latest version tag
rm -rf $pkgname
- git clone --depth 1 https://github.com/processing/processing4.git $pkgname
+ git clone --depth 1000 https://github.com/processing/processing4.git $pkgname
# Create .desktop file
gendesk -f -n --pkgname=processing4 --pkgdesc="$pkgdesc" --name="Processing 4"