summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2021-10-12 00:09:57 +0200
committerTorben2021-10-12 00:09:57 +0200
commit41803f2751cf2a368ce7776f0e06f84f2089ae91 (patch)
tree8bcff52188ae81b03cdb1256fc6ec1221c0d5dc9
parentd64d4fb29788b2d57b1df9c36007ebc7bfa16d4d (diff)
downloadaur-41803f2751cf2a368ce7776f0e06f84f2089ae91.tar.gz
Require jdk 17 for building
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 225b8c8b7980..5df04b613036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,8 @@ pkgbase = processing4-git
arch = x86_64
license = GPL
license = LGPL
+ makedepends = java-environment=17
makedepends = ant
- makedepends = jdk11-openjdk
makedepends = gendesk
makedepends = unzip
depends = libgl
diff --git a/PKGBUILD b/PKGBUILD
index 09142ad6ba52..ed6064287cbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url='https://github.com/processing/processing4'
license=(GPL LGPL)
provides=('processing' 'processing4')
depends=('libgl')
-makedepends=('ant' 'jdk11-openjdk' 'gendesk' 'unzip')
+makedepends=('java-environment=17' 'ant' 'gendesk' 'unzip')
options=(!strip)
source=('https://download.processing.org/reference.zip'
disable_update_check.patch)
@@ -42,7 +42,7 @@ prepare() {
build() {
cd "$pkgname/build"
- PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" ant build
+ PATH="/usr/lib/jvm/java-17-openjdk/bin/:$PATH" ant build
}
package() {