summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2022-01-31 13:02:30 +0100
committerTorben2022-01-31 13:02:30 +0100
commit7cf4be37e71e8d747ae5ef7ed18dc9eb0a11f9a8 (patch)
tree75604c1757f26550489197a240fa216fec54e1b2
parent6a0333b4c6f9bb2460d479e3ef0b6400b70038f8 (diff)
downloadaur-7cf4be37e71e8d747ae5ef7ed18dc9eb0a11f9a8.tar.gz
Update patch files; Remove last JFX related patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--no_jdk_download.patch28
-rw-r--r--use_system_libraries.patch26
4 files changed, 22 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7516c1a9a70..be7db9b54290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = processing4-git
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = 4.0b3.r92.g2e7b548a7
- pkgrel = 2
+ pkgver = 4.0b4.r65.g5fb933e29
+ pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
license = GPL
@@ -16,15 +16,11 @@ pkgbase = processing4-git
provides = processing4
conflicts = processing
options = !strip
- source = https://download.processing.org/reference.zip
source = disable_update_check.patch
source = no_ffmpeg_download.patch
source = no_jdk_download.patch
- source = use_system_libraries.patch
- sha256sums = fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
sha256sums = b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126
- sha256sums = 4d8bd4730a75b0288eb20230fc766523aa1cdb105bcc7ec893c7215f047bc234
- sha256sums = 15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb
+ sha256sums = 5e0cbbaf93fd4cf104fabe82c0ff98535bdae31f70d6e92ae7851477a40456d6
pkgname = processing4-git
diff --git a/PKGBUILD b/PKGBUILD
index 6daaaad0e4fa..c7f7a75f5c35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4-git
-pkgver=4.0b3.r92.g2e7b548a7
-pkgrel=2
+pkgver=4.0b4.r65.g5fb933e29
+pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
url='https://github.com/processing/processing4'
@@ -12,16 +12,12 @@ conflicts=('processing')
depends=( 'jdk-openjdk' 'java-openjfx')
makedepends=('ant' 'gendesk' 'rsync' 'unzip')
options=(!strip)
-source=('https://download.processing.org/reference.zip'
- disable_update_check.patch
+source=(disable_update_check.patch
no_ffmpeg_download.patch
- no_jdk_download.patch
- use_system_libraries.patch)
-sha256sums=('fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
- '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
+ no_jdk_download.patch)
+sha256sums=('35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
'b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126'
- '4d8bd4730a75b0288eb20230fc766523aa1cdb105bcc7ec893c7215f047bc234'
- '15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb')
+ '5e0cbbaf93fd4cf104fabe82c0ff98535bdae31f70d6e92ae7851477a40456d6')
pkgver() {
cd "$srcdir/$pkgname"
@@ -38,17 +34,10 @@ prepare() {
# Create .desktop file
gendesk -f -n --pkgname=processing --pkgdesc="$pkgdesc" --name="Processing" --exec="processing %f" --mimetypes="text/x-processing"
- # Copy reference.zip to the java directory
- mkdir -p $pkgname/java
- cp reference.zip $pkgname/java/
-
# Don't download packages that can be provided via dependencies
patch $pkgname/build/build.xml < no_jdk_download.patch
patch $pkgname/build/shared/tools/MovieMaker/build.xml < no_ffmpeg_download.patch
- # Use system libraries during build process
- patch $pkgname/core/build.xml < use_system_libraries.patch
-
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
}
diff --git a/no_jdk_download.patch b/no_jdk_download.patch
index a88764082ab7..b5efe69d5c26 100644
--- a/no_jdk_download.patch
+++ b/no_jdk_download.patch
@@ -1,30 +1,30 @@
---- build.xml.orig 2022-01-20 09:27:03.184138511 +0100
-+++ build.xml.mod 2022-01-20 09:34:06.541856662 +0100
-@@ -982,7 +982,7 @@
+--- build.xml.orig 2022-01-31 12:44:46.824038995 +0100
++++ build.xml.patched 2022-01-31 12:47:21.567810435 +0100
+@@ -940,7 +940,7 @@
</if>
</target>
-- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
-+ <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
+- <target name="linux-build" depends="revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-rpi" description="Build Linux version">
++ <target name="linux-build" depends="revision-check, linux-check-os, subprojects-build, subprojects-build-rpi" description="Build Linux version">
<mkdir dir="linux/work" />
<copy todir="linux/work" preservelastmodified="true">
-@@ -1048,47 +1048,6 @@
+@@ -1014,45 +1014,6 @@
<copy file="linux/processing-pde.xml" todir="linux/work/lib" />
<copy file="linux/appdata.xml" todir="linux/work/lib" />
<copy file="linux/desktop.template" todir="linux/work/lib" />
-
--<!--
+- <!--
- Cannot use ant version of tar because it doesn't preserve properties.
- <untar compression="gzip"
- dest="linux/work"
- src="linux/jdk.tgz"
- overwrite="false"/>
---->
+- -->
-
--<!--
-- http://www.gnu.org/software/tar/manual/html_section/transform.html
---->
+- <!--
+- http://www.gnu.org/software/tar/manual/html_section/transform.html
+- -->
- <exec executable="tar" dir="linux">
- <!-- Change directory -->
- <!--
@@ -36,12 +36,10 @@
- <arg value="../${jdk.archive.path}"/>
- </exec>
-
-- <property name="jdk.dir" value="jdk-${jdk.detail}+${jdk.build}/" />
--
- <exec executable="rsync" dir="linux">
- <arg value="-a" />
- <arg value="--delete" />
-- <arg value="${jdk.dir}" />
+- <arg value="${jdk.folder}/" />
- <arg value="work/java/" />
- </exec>
-
@@ -52,7 +50,7 @@
-
- <exec executable="rm">
- <arg value="-r"/>
-- <arg line="linux/jdk-${jdk.detail}+${jdk.build}"/>
+- <arg line="linux/${jdk.folder}"/>
- </exec>
</target>
diff --git a/use_system_libraries.patch b/use_system_libraries.patch
deleted file mode 100644
index 67d2871b301b..000000000000
--- a/use_system_libraries.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/core/build.xml b/core/build.xml
-index db633fff9..f984ae71c 100644
---- a/core/build.xml
-+++ b/core/build.xml
-@@ -66,14 +66,14 @@
- <pathelement location="library/gluegen-rt.jar" />
-
- <!-- <pathelement location="library/javafx-swt.jar" /> -->
-- <pathelement location="library/javafx.base.jar" />
-- <pathelement location="library/javafx.controls.jar" />
-- <pathelement location="library/javafx.fxml.jar" />
-- <pathelement location="library/javafx.graphics.jar" />
-- <pathelement location="library/javafx.media.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar" />
- <!-- error? it's not a .jar, but is this how config is handled? [fry 210619] -->
-- <pathelement location="library/javafx.properties" />
-- <pathelement location="library/javafx.swing.jar" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.properties" />
-+ <pathelement location="/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar" />
- <!-- <pathelement location="library/javafx.web.jar" /> -->
- </path>
-