summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2021-10-12 00:32:35 +0200
committerTorben2021-10-12 00:32:35 +0200
commit9606691006a823351dbee5092f8695b9c853c8e7 (patch)
tree56af7b85bc11e1706a08b9a3b54196e3e5631644
parent713c95f96155d46c49d0e15053efe377e72cc8fa (diff)
downloadaur-9606691006a823351dbee5092f8695b9c853c8e7.tar.gz
Disable native file dialog
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--disable_native_dialogs.patch11
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5df04b613036..399de2ed03a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,9 @@ pkgbase = processing4-git
options = !strip
source = https://download.processing.org/reference.zip
source = disable_update_check.patch
+ source = disable_native_dialogs.patch
sha256sums = fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
+ sha256sums = 500d00811031c0445416b6112972aa1f7a377092dd3b8565d79ead3fdfc62451
pkgname = processing4-git
diff --git a/PKGBUILD b/PKGBUILD
index b99b4d439977..0cab9371f952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,11 @@ depends=('libgl')
makedepends=('java-environment=17' 'ant' 'gendesk' 'unzip')
options=(!strip)
source=('https://download.processing.org/reference.zip'
- disable_update_check.patch)
+ disable_update_check.patch
+ disable_native_dialogs.patch)
sha256sums=('fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
- '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30')
+ '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
+ '500d00811031c0445416b6112972aa1f7a377092dd3b8565d79ead3fdfc62451')
pkgver() {
cd "$srcdir/$pkgname"
@@ -37,6 +39,9 @@ prepare() {
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
+
+ # Disable native dialogs in default preferences
+ patch $pkgname/build/shared/lib/defaults.txt < disable_native_dialogs.patch
}
build() {
diff --git a/disable_native_dialogs.patch b/disable_native_dialogs.patch
new file mode 100644
index 000000000000..678740dd05b4
--- /dev/null
+++ b/disable_native_dialogs.patch
@@ -0,0 +1,11 @@
+--- a/build/shared/lib/defaults.txt
++++ b/build/shared/lib/defaults.txt
+@@ -74,7 +74,7 @@
+ recent.count = 10
+
+ # Default to the native (AWT) file selector where possible
+-chooser.files.native = true
++chooser.files.native = false
+ # We were shutting this off on macOS because it broke Copy/Paste:
+ # https://github.com/processing/processing/issues/1035
+ # https://github.com/processing/processing4/issues/77