summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2022-01-20 09:54:09 +0100
committerTorben2022-01-20 09:54:48 +0100
commitad479649c693c20c0611859c92167e8444a55e2d (patch)
tree429c1fd9c583299fc09ea34df0d984ffd10c33d4
parentc40699001508dbe0a1c5863a5f0ffccc49d920aa (diff)
downloadaur-ad479649c693c20c0611859c92167e8444a55e2d.tar.gz
Update patch files; Remove obsolete patches
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--fix_theme_engine.patch20
-rw-r--r--no_jdk_download.patch19
-rw-r--r--no_jfx_download.patch11
-rw-r--r--use_system_jdk.patch20
6 files changed, 11 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aefdbae5943b..9975bed5ec16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = processing4-git
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = 4.0b2.r37.g82fcf9521
+ pkgver = 4.0b3.r92.g2e7b548a7
pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
@@ -17,19 +17,13 @@ pkgbase = processing4-git
options = !strip
source = https://download.processing.org/reference.zip
source = disable_update_check.patch
- source = fix_theme_engine.patch
source = no_ffmpeg_download.patch
source = no_jdk_download.patch
- source = no_jfx_download.patch
- source = use_system_jdk.patch
source = use_system_libraries.patch
sha256sums = fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
- sha256sums = 24b8a3e18b6e3a0de9422e4dbde46cceb91385f7ad6bdc89ec0a9614e082c977
sha256sums = b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126
- sha256sums = 0ef5266575db0fe6bde436e5a3205ca848440b3006bccb4c20fe8d7b98951ee9
- sha256sums = dc733c1cb5a41cb06ef0f9ea01d701fd9ac7713b5817b4fe79d7076a505a7c44
- sha256sums = d2877ad894f76594675534026ee91581f6357a3892afe2fd0efcf86de746c7cb
+ sha256sums = 4d8bd4730a75b0288eb20230fc766523aa1cdb105bcc7ec893c7215f047bc234
sha256sums = 15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb
pkgname = processing4-git
diff --git a/PKGBUILD b/PKGBUILD
index 7b1b35fb163d..700754ea1a4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4-git
-pkgver=4.0b2.r37.g82fcf9521
+pkgver=4.0b3.r92.g2e7b548a7
pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
@@ -14,19 +14,13 @@ makedepends=('ant' 'gendesk' 'unzip')
options=(!strip)
source=('https://download.processing.org/reference.zip'
disable_update_check.patch
- fix_theme_engine.patch
no_ffmpeg_download.patch
no_jdk_download.patch
- no_jfx_download.patch
- use_system_jdk.patch
use_system_libraries.patch)
sha256sums=('fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
- '24b8a3e18b6e3a0de9422e4dbde46cceb91385f7ad6bdc89ec0a9614e082c977'
'b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126'
- '0ef5266575db0fe6bde436e5a3205ca848440b3006bccb4c20fe8d7b98951ee9'
- 'dc733c1cb5a41cb06ef0f9ea01d701fd9ac7713b5817b4fe79d7076a505a7c44'
- 'd2877ad894f76594675534026ee91581f6357a3892afe2fd0efcf86de746c7cb'
+ '4d8bd4730a75b0288eb20230fc766523aa1cdb105bcc7ec893c7215f047bc234'
'15119264b6ae7b154f033261ba93535c2d1b5e2b9d849f3999dd7881cc9e49cb')
pkgver() {
@@ -48,17 +42,12 @@ prepare() {
mkdir -p $pkgname/java
cp reference.zip $pkgname/java/
- # Don't download JDK and JFX files during Ant's build process
+ # Don't download packages that can be provided via dependencies
patch $pkgname/build/build.xml < no_jdk_download.patch
- patch $pkgname/java/libraries/javafx/build.xml < no_jfx_download.patch
patch $pkgname/build/shared/tools/MovieMaker/build.xml < no_ffmpeg_download.patch
# Use system libraries during build process
patch $pkgname/core/build.xml < use_system_libraries.patch
- patch $pkgname/build/shared/tools/ThemeEngine/build.xml < fix_theme_engine.patch
-
- # Use system JDK to start processing
- patch $pkgname/build/linux/processing < use_system_jdk.patch
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
diff --git a/fix_theme_engine.patch b/fix_theme_engine.patch
deleted file mode 100644
index 231d12d5ffc0..000000000000
--- a/fix_theme_engine.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build/shared/tools/ThemeEngine/build.xml
-+++ b/build/shared/tools/ThemeEngine/build.xml
-@@ -6,7 +6,7 @@
- <property name="core.bin.path" location="../../../../core/bin" />
-
- <property name="javafx.path"
-- location="../../../../java/libraries/javafx/library/macosx" />
-+ location="/usr/lib/jvm/java-17-openjdk/lib/" />
-
- <target name="clean" description="Clean the build directories">
- <delete dir="bin" />
-@@ -26,7 +26,7 @@
- <pathelement location="${app.bin.path}" />
- <pathelement location="${core.bin.path}" />
-
-- <fileset dir="${javafx.path}/modules">
-+ <fileset dir="${javafx.path}">
- <include name="**/*.jar" />
- </fileset>
- </classpath>
diff --git a/no_jdk_download.patch b/no_jdk_download.patch
index 550c37374d96..a88764082ab7 100644
--- a/no_jdk_download.patch
+++ b/no_jdk_download.patch
@@ -1,7 +1,7 @@
---- a/build/build.xml
-+++ b/build/build.xml
-@@ -1008,7 +1008,7 @@
- </if>
+--- build.xml.orig 2022-01-20 09:27:03.184138511 +0100
++++ build.xml.mod 2022-01-20 09:34:06.541856662 +0100
+@@ -982,7 +982,7 @@
+ </if>
</target>
- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
@@ -9,7 +9,7 @@
<mkdir dir="linux/work" />
<copy todir="linux/work" preservelastmodified="true">
-@@ -1098,54 +1098,6 @@
+@@ -1048,47 +1048,6 @@
<copy file="linux/processing-pde.xml" todir="linux/work/lib" />
<copy file="linux/appdata.xml" todir="linux/work/lib" />
<copy file="linux/desktop.template" todir="linux/work/lib" />
@@ -33,7 +33,7 @@
- <arg value="-xzpf" />
- -->
- <arg value="xfz" />
-- <arg value="../${jdk.tgz.path}"/>
+- <arg value="../${jdk.archive.path}"/>
- </exec>
-
- <property name="jdk.dir" value="jdk-${jdk.detail}+${jdk.build}/" />
@@ -54,13 +54,6 @@
- <arg value="-r"/>
- <arg line="linux/jdk-${jdk.detail}+${jdk.build}"/>
- </exec>
--
-- <!--
-- <exec executable="rm">
-- <arg value="-r"/>
-- <arg line="${jfx.path.dist}"/>
-- </exec>
-- -->
</target>
<target name="linux-run" depends="linux-build"
diff --git a/no_jfx_download.patch b/no_jfx_download.patch
deleted file mode 100644
index d000da10b992..000000000000
--- a/no_jfx_download.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/java/libraries/javafx/build.xml
-+++ b/java/libraries/javafx/build.xml
-@@ -167,7 +167,6 @@
- nowarn="true" />
- </target>
-
-- <target name="build" depends="compile" description="Build JavaFX renderer">
-- <jar basedir="bin" destfile="library/javafx.jar" />
-+ <target name="build" description="Build JavaFX renderer">
- </target>
- </project>
diff --git a/use_system_jdk.patch b/use_system_jdk.patch
deleted file mode 100644
index 5ac14aec6ce9..000000000000
--- a/use_system_jdk.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build/linux/processing
-+++ b/build/linux/processing
-@@ -66,7 +66,7 @@ APPDIR=`dirname "$APPDIR"`
- log APPDIR
-
- # Try using a local JDK from the same directory as this script
--JDKDIR=`readlink -f "$APPDIR/java"`
-+JDKDIR=`readlink -f /usr/lib/jvm/java-17-openjdk`
- make_jdkcp "$JDKDIR"
- log SUCCESS
-
-@@ -113,6 +113,6 @@ else
- fi
- cd "$APPDIR"
-
-- #java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64/modules --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing,javafx.web -Xmx512m processing.app.Base "$SKETCH" &
-- java -Djna.nosys=true -Dpython.console.encoding=UTF-8 -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64/modules --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing,javafx.web -Xmx512m processing.app.ui.Splash "$SKETCH" &
-+ #java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:/usr/lib/jvm/java-17-openjdk/lib --module-path=/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.web -Xmx512m processing.app.Base "$SKETCH" &
-+ java -Djna.nosys=true -Dpython.console.encoding=UTF-8 -Djava.library.path=lib:/usr/lib/jvm/java-17-openjdk/lib --module-path=/usr/lib/jvm/java-17-openjdk/lib/javafx.base.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.controls.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.fxml.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.graphics.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.media.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.swing.jar:/usr/lib/jvm/java-17-openjdk/lib/javafx.web -Xmx512m processing.app.ui.Splash "$SKETCH" &
- fi