summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-06-18 10:32:57 +0200
committerTorben2020-06-18 10:32:57 +0200
commitbf0b4bc517543a8f6ebabe5d94330ea44b3caa6c (patch)
treedbeef89084f1cba0a20001b26c15dca4953e41d8
parent6d1412faf55b9c22eef430ce054196b93626d1ba (diff)
downloadaur-bf0b4bc517543a8f6ebabe5d94330ea44b3caa6c.tar.gz
Use the downloaded jogl packages in the build process again
-rw-r--r--PKGBUILD7
-rw-r--r--use_system_libraries.patch19
2 files changed, 8 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7be28f3c0cd..43cb6e762335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ pkgdesc='Programming environment for creating images, animations and interaction
url='https://github.com/processing/processing4'
license=(GPL LGPL)
conflicts=(processing processing-bin processing-jdk8)
-depends=('jdk11-openjdk' 'java11-openjfx' 'jogl' 'libgl')
+depends=('jdk11-openjdk' 'java11-openjfx' 'libgl')
+# TODO add jogl as make-dependency once a package for version 2.4.0 exists
makedepends=('ant' 'gendesk' 'unzip')
options=(!strip)
source=('https://download.processing.org/reference.zip'
@@ -22,7 +23,7 @@ sha256sums=('2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
'fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
'a07184b87d3d2ccd35525a0721df787973f92487bae367a0668abd3f64134263'
- 'db6d31c42c13f41b2fde531018927d994c4ae13a04848c4afb0762620b0f0903')
+ '6115cced44fcf1cadd945cbb5a09692a3956259c294351bdec27469f1fd03163')
pkgver() {
cd "$srcdir/$pkgname"
@@ -45,6 +46,8 @@ prepare() {
# Don't download any files during Ant's build process
patch $pkgname/build/build.xml < no_downloads.patch
+
+ # Use system libraries instead of the ones included in the processing4 repo
patch $pkgname/core/build.xml < use_system_libraries.patch
# Disable update check in default preferences
diff --git a/use_system_libraries.patch b/use_system_libraries.patch
index 0d9a32c60c08..3357bb6162cc 100644
--- a/use_system_libraries.patch
+++ b/use_system_libraries.patch
@@ -1,20 +1,9 @@
--- build_core.xml.orig 2020-06-13 00:09:40.000000000 +0200
+++ build_core.xml 2020-06-17 15:54:22.945551353 +0200
-@@ -29,7 +29,7 @@
- <property name="jogl.url"
- value="https://jogamp.org/deployment/archive/rc/v2.4.0-rc-20200307/jar" />
-
-- <available file="library/jogl-all.jar" property="jogl.present" />
-+ <available file="/usr/share/java/jogl/jogl-all.jar" property="jogl.present" />
-
- <!-- ok to ignore failed downloads if we at least have a version that's local -->
- <condition property="jogl.ignorable" value="false" else="true">
-@@ -58,17 +58,17 @@
- </target>
-
+@@ -60,15 +60,15 @@
<path id="classpath.base">
-- <pathelement location="library/jogl-all.jar" />
-- <pathelement location="library/gluegen-rt.jar" />
+ <pathelement location="library/jogl-all.jar" />
+ <pathelement location="library/gluegen-rt.jar" />
- <pathelement location="library/javafx-swt.jar" />
- <pathelement location="library/javafx.base.jar" />
- <pathelement location="library/javafx.controls.jar" />
@@ -24,8 +13,6 @@
- <pathelement location="library/javafx.properties" />
- <pathelement location="library/javafx.swing.jar" />
- <pathelement location="library/javafx.web.jar" />
-+ <pathelement location="/usr/share/java/jogl/jogl-all.jar" />
-+ <pathelement location="/usr/share/java/jogl/gluegen-rt.jar" />
+ <pathelement location="/usr/lib/jvm/java-11-openjdk/lib/javafx-swt.jar" />
+ <pathelement location="/usr/lib/jvm/java-11-openjdk/lib/javafx.base.jar" />
+ <pathelement location="/usr/lib/jvm/java-11-openjdk/lib/javafx.controls.jar" />