summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-06-13 14:15:06 +0200
committerTorben2020-06-13 14:15:06 +0200
commit8bc4c899f0f2717aadb0af012c48fcd3742924f4 (patch)
tree21a054f25775c0401a61768158f5cf86cec2dd60
parent97e888f17e61d2f5ebae932a099db96bb29d152e (diff)
downloadaur-8bc4c89.tar.gz
Apply patch to always use java-8-jdk
-rw-r--r--PKGBUILD5
-rw-r--r--always_use_java-8-jdk.patch12
2 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fbb99d086e4..3c9b4ecc6702 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,12 @@ options=(!strip)
# version number above 0266 in addition to the ordinary version number.
source=("https://github.com/processing/processing/archive/processing-0$((266+${pkgver##3.5.}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
+ always_use_java-8-jdk.patch
derive_jdk_from_path.patch
no_downloads.patch)
sha256sums=('99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925'
'2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
+ '8255ba154118884e51e3b9b7174814f7de8fcf7c380ce6f8666192adb6f2483c'
'00d4edeb3e1d61a4e7a0fec12dfe340091f6a067fcadf3654d29e5286fc7e1df'
'e3490e4276d1bd33a00d8accad3d72500519477f8aca44703045d92faa342cf6')
@@ -44,6 +46,9 @@ prepare() {
# Derive JDK location from java binary found in PATH
patch $pkgname/build/linux/processing < derive_jdk_from_path.patch
+
+ # Always use Oracle's JDK to run processing
+ patch $pkgname/build/linux/processing < always_use_java-8-jdk.patch
}
build() {
diff --git a/always_use_java-8-jdk.patch b/always_use_java-8-jdk.patch
new file mode 100644
index 000000000000..2931d7f93569
--- /dev/null
+++ b/always_use_java-8-jdk.patch
@@ -0,0 +1,12 @@
+--- a/build/linux/processing 2020-01-17 17:20:35.000000000 +0100
++++ b/build/linux/processing 2020-06-13 14:02:40.924929084 +0200
+@@ -13,6 +13,9 @@
+ # Thanks to Ferdinand Kasper for this build script. [fry]
+
+
++# Always use Oracle's JDK to run processing
++PATH="/usr/lib/jvm/java-8-jdk/bin/:$PATH"
++
+ # JARs required from JDK (anywhere in/below the JDK home directory)
+ JDKLIBS="rt.jar"
+