summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-06-13 14:32:04 +0200
committerTorben2020-06-13 14:32:04 +0200
commit188ad1f75bd03c45d7499f338f3e01e687f1710e (patch)
tree547f29872c39d6bab536b721aca21d2f89f7d5d2
parent3e970f8e53384853d6375854d83741f5ee539781 (diff)
downloadaur-188ad1f75bd03c45d7499f338f3e01e687f1710e.tar.gz
Disable update check in default preferences
-rw-r--r--PKGBUILD5
-rw-r--r--disable_update_check.patch11
2 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ead176b2b13a..710d61a6002d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,11 +21,13 @@ source=("https://github.com/processing/processing/archive/processing-0$((266+${p
'https://download.processing.org/reference.zip'
always_use_java-8-jdk.patch
derive_jdk_from_path.patch
+ disable_update_check.patch
no_downloads.patch)
sha256sums=('99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925'
'2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
'8255ba154118884e51e3b9b7174814f7de8fcf7c380ce6f8666192adb6f2483c'
'fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611'
+ '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
'52bdda3ce6368df469172889c53091f7284806e2a1524b012e236736de98f646')
prepare() {
@@ -44,6 +46,9 @@ prepare() {
# Don't download any files during Ant's build process
patch $pkgname/build/build.xml < no_downloads.patch
+ # Disable update check in default preferences
+ patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
+
# Derive JDK location from java binary found in PATH
patch $pkgname/build/linux/processing < derive_jdk_from_path.patch
diff --git a/disable_update_check.patch b/disable_update_check.patch
new file mode 100644
index 000000000000..00e14ee85ab2
--- /dev/null
+++ b/disable_update_check.patch
@@ -0,0 +1,11 @@
+--- a/build/shared/lib/defaults.txt 2020-01-17 17:20:35.000000000 +0100
++++ b/build/shared/lib/defaults.txt 2020-06-13 14:23:41.897313082 +0200
+@@ -82,7 +82,7 @@
+ # by default, check the processing server for any updates
+ # (please avoid disabling, this also helps us know basic numbers
+ # on how many people are using Processing)
+-update.check = true
++update.check = false
+
+ # on windows, automatically associate .pde files with processing.exe
+ platform.auto_file_type_associations = true