summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2021-10-11 22:53:45 +0200
committerTorben2021-10-11 23:13:24 +0200
commit211b36624012f5ffa0ca412f7c4160bee6eb8b55 (patch)
treec5b20ecd07bbd064abf97a736471064c8fc55de9
parentbd746f105612d22d0af258974a260a74fee6ad69 (diff)
downloadaur-211b36624012f5ffa0ca412f7c4160bee6eb8b55.tar.gz
Disable native file dialog
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--disable_native_dialogs.patch11
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 644a5abff00d..ce13001ebd11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = processing4
pkgdesc = Programming environment for creating images, animations and interactions
pkgver = 4.0b2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/processing/processing4
arch = x86_64
license = GPL
@@ -16,8 +16,10 @@ pkgbase = processing4
source = https://github.com/processing/processing4/archive/processing-1277-4.0b2.tar.gz
source = https://download.processing.org/reference.zip
source = disable_update_check.patch
+ source = disable_native_dialogs.patch
sha256sums = 060a126877d63ddb048cd389c505f0d502ba4f00bb59be38b99250b1f7006b2d
sha256sums = fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
+ sha256sums = 500d00811031c0445416b6112972aa1f7a377092dd3b8565d79ead3fdfc62451
pkgname = processing4
diff --git a/PKGBUILD b/PKGBUILD
index ff40138e866f..8a11022fa303 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=processing4
pkgver=4.0b2
-pkgrel=1
+pkgrel=2
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
url='https://github.com/processing/processing4'
@@ -13,10 +13,12 @@ provides=('processing')
options=(!strip)
source=("https://github.com/processing/processing4/archive/processing-$((1275+${pkgver##4.0b}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
- disable_update_check.patch)
+ disable_update_check.patch
+ disable_native_dialogs.patch)
sha256sums=('060a126877d63ddb048cd389c505f0d502ba4f00bb59be38b99250b1f7006b2d'
'fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
- '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30')
+ '35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
+ '500d00811031c0445416b6112972aa1f7a377092dd3b8565d79ead3fdfc62451')
prepare() {
# Create .desktop file
@@ -31,6 +33,9 @@ prepare() {
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
+
+ # Disable native dialogs in default preferences
+ patch $pkgname/build/shared/lib/defaults.txt < disable_native_dialogs.patch
}
build() {
diff --git a/disable_native_dialogs.patch b/disable_native_dialogs.patch
new file mode 100644
index 000000000000..678740dd05b4
--- /dev/null
+++ b/disable_native_dialogs.patch
@@ -0,0 +1,11 @@
+--- a/build/shared/lib/defaults.txt
++++ b/build/shared/lib/defaults.txt
+@@ -74,7 +74,7 @@
+ recent.count = 10
+
+ # Default to the native (AWT) file selector where possible
+-chooser.files.native = true
++chooser.files.native = false
+ # We were shutting this off on macOS because it broke Copy/Paste:
+ # https://github.com/processing/processing/issues/1035
+ # https://github.com/processing/processing4/issues/77