summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-06-10 17:08:16 +0200
committerTorben2020-06-10 23:50:11 +0200
commit25d2c07ead309040cff3ba0a9867b3f255975dcf (patch)
tree2b7cf5bdee682a8ee17e5d97811b48397bac20c4
parentd757116a787e4a479ccfbd5bc938edc2c2cb052f (diff)
downloadaur-25d2c07ead309040cff3ba0a9867b3f255975dcf.tar.gz
Clean up, add contributors and update description
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba1a15ec876..4f9e56c9c78a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = processing-jdk8
- pkgdesc = Programming environment for creating images, animations and interactions
+ pkgdesc = Programming environment for creating images, animations and interactions (uses Oracle JDK 8)
pkgver = 3.5.4
pkgrel = 1
url = https://www.processing.org/
diff --git a/PKGBUILD b/PKGBUILD
index 27b563468689..8f5f5f1efb97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: Torben <git at letorbi dot com>
+# Contributor: lesto <mombelli.mauro at gmail dot com>
+# Contributor: Antonio Rojas <arojas at archlinux dot org>
+# Contributor: Alexander F. Rødseth <xyproto at archlinux dot org>
pkgname=processing-jdk8
pkgver=3.5.4
pkgrel=1
arch=(x86_64)
-pkgdesc='Programming environment for creating images, animations and interactions'
+pkgdesc='Programming environment for creating images, animations and interactions (uses Oracle JDK 8)'
url='https://www.processing.org/'
license=(GPL LGPL)
provides=(processing)
conflicts=(processing processing-bin)
-# Can upgrade to OpenJDK 10 once java-openjfx has been upgraded to support it
depends=('jdk8' 'libgl')
makedepends=('apache-ant' 'gendesk' 'unzip')
options=(!strip)
# The Processing version scheme for the 3.5.x series uses a special magical
# version number above 0266 in addition to the ordinary version number.
-# https is not available for reference.zip.
source=("https://github.com/processing/processing/archive/processing-0$((266+${pkgver##3.5.}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
no_downloads.patch)
@@ -62,12 +63,7 @@ package() {
ln -s "/usr/share/processing/processing" "$pkgdir/usr/bin/processing"
ln -s "/usr/share/processing/processing-java" "$pkgdir/usr/bin/processing-java"
- # Use /usr/lib/jvm/default-runtime
+ # Ensure that processing uses Oracle's JDK 8
rmdir "$pkgdir/usr/share/processing/java"
-
- # Processing does not work with OpenJDK 10 or 11, use OpenJDK 8
- #ln -s /usr/lib/jvm/default-runtime/ "$pkgdir/usr/share/processing/java"
ln -s /usr/lib/jvm/java-8-jdk/ "$pkgdir/usr/share/processing/java"
}
-
-# vim: ts=2 sw=2 et