summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-06-10 16:54:39 +0200
committerTorben2020-06-10 23:45:55 +0200
commitd757116a787e4a479ccfbd5bc938edc2c2cb052f (patch)
treebd6f007bb9922dc93ffdf062d1a2e101f8bd6da5
parentedb0aa200c8ec70cae8a5c63edc4c66b23c974f0 (diff)
downloadaur-d757116a787e4a479ccfbd5bc938edc2c2cb052f.tar.gz
Remove some more unnecessary changes and additions
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
-rw-r--r--errormessage.patch11
-rw-r--r--openjdkmsg.install14
4 files changed, 0 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6d19cc3df54..7ba1a15ec876 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,6 @@ pkgbase = processing-jdk8
pkgver = 3.5.4
pkgrel = 1
url = https://www.processing.org/
- install = openjdkmsg.install
arch = x86_64
license = GPL
license = LGPL
@@ -18,11 +17,9 @@ pkgbase = processing-jdk8
options = !strip
source = https://github.com/processing/processing/archive/processing-0270-3.5.4.tar.gz
source = https://download.processing.org/reference.zip
- source = errormessage.patch
source = no_downloads.patch
sha256sums = 99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925
sha256sums = 2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5
- sha256sums = c6e9609c514730105aab1ee9786f89488e9f49509158743ab1dbea21c1378dcf
sha256sums = e3490e4276d1bd33a00d8accad3d72500519477f8aca44703045d92faa342cf6
pkgname = processing-jdk8
diff --git a/PKGBUILD b/PKGBUILD
index d4e56c95decc..27b563468689 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,17 +13,14 @@ conflicts=(processing processing-bin)
depends=('jdk8' 'libgl')
makedepends=('apache-ant' 'gendesk' 'unzip')
options=(!strip)
-install=openjdkmsg.install
# The Processing version scheme for the 3.5.x series uses a special magical
# version number above 0266 in addition to the ordinary version number.
# https is not available for reference.zip.
source=("https://github.com/processing/processing/archive/processing-0$((266+${pkgver##3.5.}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
- errormessage.patch
no_downloads.patch)
sha256sums=('99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925'
'2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
- 'c6e9609c514730105aab1ee9786f89488e9f49509158743ab1dbea21c1378dcf'
'e3490e4276d1bd33a00d8accad3d72500519477f8aca44703045d92faa342cf6')
prepare() {
@@ -32,28 +29,13 @@ prepare() {
# Symbolic link for not having to repeat the revision number
ln -sf "processing-processing-"*"-$pkgver" $pkgname
- # Add some details to one of the error messages
- patch -p0 -i errormessage.patch
-
# Copy reference.zip to the java directory
mkdir -p $pkgname/java
cp "$srcdir/reference.zip" $pkgname/java/
- # Unpack reference.zip
- mkdir -p $pkgname/build/linux/work/modes/java
- unzip -q -u "$srcdir/reference.zip" -d $pkgname/build/linux/work/modes/java
-
- # Disable the "We only like Java from Sun and Oracle" GUI message
- sed -i 's,Messages.showWarning,\/\*Messages.showWarning,;s,null);,null);\*\/,' \
- "$pkgname/app/src/processing/app/platform/LinuxPlatform.java"
-
# Create missing directories
mkdir -p $pkgname/build/linux/work/java
- # Use the font's built-in hinting instructions
- sed 's| java| _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=gasp" java|g' \
- -i $pkgname/build/linux/processing
-
# Don't download any files during Ant's build process
patch $pkgname/build/build.xml < no_downloads.patch
}
diff --git a/errormessage.patch b/errormessage.patch
deleted file mode 100644
index 8dbfd48f1dd8..000000000000
--- a/errormessage.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- processing-jdk8/app/src/processing/app/contrib/ContributionManager.java 2018-07-26 23:59:08.000000000 +0200
-+++ processing-jdk8/app/src/processing/app/contrib/ContributionManager.java 2018-11-20 12:53:07.229171545 +0100
-@@ -206,7 +206,7 @@
- .interpolate("contrib.errors.contrib_download.timeout",
- ad.getName()));
- } else {
-- status.setErrorMessage(Language
-+ status.setErrorMessage("Could not download " + url + " to " + contribZip + " : " + Language
- .interpolate("contrib.errors.download_and_install",
- ad.getName()));
- }
diff --git a/openjdkmsg.install b/openjdkmsg.install
deleted file mode 100644
index ffd0596c5eca..000000000000
--- a/openjdkmsg.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_upgrade() {
- cat << EOF
----[ NOTE ]--------------------------------------------------------------------
- Processing does not support OpenJDK, only Java from Oracle.
- https://github.com/processing/processing/wiki/Supported-Platforms#linux
- If you encounter issues with this package, please file pull requests for
- Processing and/or OpenJDK until Processing can officially support OpenJDK.
--------------------------------------------------------------------------------
-EOF
-}
-
-post_install() {
- post_upgrade
-}