summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2023-05-12 10:53:40 +0200
committerBjoern Franke2023-05-12 10:53:40 +0200
commitac3ce7e38a07aba1bb02637332b0268c00765a99 (patch)
tree278fe091f9b4d7054ef259b1f5826f255019aad2
parent83806909a3c7af0d418093add62b7b7feeff5cb9 (diff)
downloadaur-procmail.tar.gz
remove old patches
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fix_memory_allocation_bug.diff11
-rw-r--r--formisc.c.patch14
-rw-r--r--procmail-3.22-getline.patch56
5 files changed, 2 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51777010c76a..4c449ff40575 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = procmail
pkgdesc = Highly configurable auto mail processing.
pkgver = 3.24
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/BuGlessRB/procmail
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 87bf24546432..eb4f1bbff5aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=procmail
pkgver=3.24
-pkgrel=2
+pkgrel=3
pkgdesc="Highly configurable auto mail processing."
arch=('x86_64')
#url="http://www.procmail.org" # offline
diff --git a/fix_memory_allocation_bug.diff b/fix_memory_allocation_bug.diff
deleted file mode 100644
index ba95429226a7..000000000000
--- a/fix_memory_allocation_bug.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/pipes.c.old 2002-12-02 23:45:15.000000000 +0100
-+++ b/src/pipes.c 2002-12-02 23:45:24.000000000 +0100
-@@ -194,7 +194,7 @@
- makeblock(&temp,Stdfilled);
- tmemmove(temp.p,Stdout,Stdfilled);
- readdyn(&temp,&Stdfilled,Stdfilled+backlen+1);
-- Stdout=realloc(Stdout,&Stdfilled+1);
-+ Stdout=realloc(Stdout,Stdfilled+1);
- tmemmove(Stdout,temp.p,Stdfilled+1);
- freeblock(&temp);
- retStdout(Stdout,pwait&&pipw,!backblock);
diff --git a/formisc.c.patch b/formisc.c.patch
deleted file mode 100644
index 59102b352175..000000000000
--- a/formisc.c.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/formisc.c b/src/formisc.c
-index d91b227..6c7594b 100644
---- a/src/formisc.c
-+++ b/src/formisc.c
-@@ -103,7 +103,7 @@ void loadsaved(sp)const struct saved*const sp; /* load some saved text */
- }
- /* append to buf */
- void loadbuf(text,len)const char*const text;const size_t len;
--{ if(buffilled+len>buflen) /* buf can't hold the text */
-+{ while(buffilled+len>buflen) /* buf can't hold the text */
- buf=realloc(buf,buflen+=Bsize);
- tmemmove(buf+buffilled,text,len);buffilled+=len;
- }
-
diff --git a/procmail-3.22-getline.patch b/procmail-3.22-getline.patch
deleted file mode 100644
index fb9a4ec6efb5..000000000000
--- a/procmail-3.22-getline.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -up procmail-3.22/src/fields.c.getline procmail-3.22/src/fields.c
---- procmail-3.22/src/fields.c.getline 2001-09-11 06:57:08.000000000 +0200
-+++ procmail-3.22/src/fields.c 2009-06-30 16:10:36.000000000 +0200
-@@ -110,16 +110,16 @@ void dispfield(p)register const struct f
- /* try and append one valid field to rdheader from stdin */
- int readhead P((void))
- { int idlen;
-- getline();
-+ get_line();
- if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
- return 0;
- if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
- { if(rdheader)
- return 0; /* the From_ line was a fake! */
-- for(;buflast=='>';getline()); /* gather continued >From_ lines */
-+ for(;buflast=='>';get_line()); /* gather continued >From_ lines */
- }
- else
-- for(;;getline()) /* get the rest of the continued field */
-+ for(;;get_line()) /* get the rest of the continued field */
- { switch(buflast) /* will this line be continued? */
- { case ' ':case '\t': /* yep, it sure is */
- continue;
-diff -up procmail-3.22/src/formail.c.getline procmail-3.22/src/formail.c
---- procmail-3.22/src/formail.c.getline 2009-06-30 16:00:40.000000000 +0200
-+++ procmail-3.22/src/formail.c 2009-06-30 16:10:49.000000000 +0200
-@@ -819,7 +819,7 @@ splitit: { if(!lnl) /* did the p
- { if(split) /* gobble up the next start separator */
- { buffilled=0;
- #ifdef sMAILBOX_SEPARATOR
-- getline();buffilled=0; /* but only if it's defined */
-+ get_line();buffilled=0; /* but only if it's defined */
- #endif
- if(buflast!=EOF) /* if any */
- goto splitit;
-diff -up procmail-3.22/src/formisc.c.getline procmail-3.22/src/formisc.c
---- procmail-3.22/src/formisc.c.getline 2001-06-29 04:20:45.000000000 +0200
-+++ procmail-3.22/src/formisc.c 2009-06-30 16:12:20.000000000 +0200
-@@ -115,7 +115,7 @@ void loadchar(c)const int c; /* a
- buf[buffilled++]=c;
- }
-
--int getline P((void)) /* read a newline-terminated line */
-+int get_line P((void)) /* read a newline-terminated line */
- { if(buflast==EOF) /* at the end of our Latin already? */
- { loadchar('\n'); /* fake empty line */
- return EOF; /* spread the word */
-diff -up procmail-3.22/src/formisc.h.getline procmail-3.22/src/formisc.h
---- procmail-3.22/src/formisc.h.getline 1999-04-19 08:42:15.000000000 +0200
-+++ procmail-3.22/src/formisc.h 2009-06-30 16:10:02.000000000 +0200
-@@ -17,4 +17,4 @@ void
- char*
- skipwords P((char*start));
- int
-- getline P((void));
-+ get_line P((void));