summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas 'Segaja' Schleifer2021-11-15 17:27:54 +0100
committerAndreas 'Segaja' Schleifer2021-11-15 17:27:54 +0100
commit32f8805580ee1f54d9f006876832351c64cfb517 (patch)
treec31c12fdcd8916802057ca24d4daa9d86531eeea
parentde6fea21d3704180a3065e7ed873465d3128dc1c (diff)
downloadaur-32f8805580ee1f54d9f006876832351c64cfb517.tar.gz
remove version from source checkout
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3df1dcc2d4e3..7331d1156d41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = procpath
pkgdesc = A process tree analysis workbench
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://heptapod.host/saajns/procpath
arch = any
license = LGPL3
@@ -10,7 +10,7 @@ pkgbase = procpath
depends = python
depends = python-jsonpyth
depends = python-pygal
- source = procpath-1.4.0::hg+https://heptapod.host/saajns/procpath#revision=4e8ba95a83be
+ source = procpath::hg+https://heptapod.host/saajns/procpath#revision=4e8ba95a83be
sha512sums = SKIP
pkgname = procpath
diff --git a/PKGBUILD b/PKGBUILD
index 5bb54a066dd2..85801ba5bef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,31 @@
pkgname=procpath
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A process tree analysis workbench"
arch=(any)
url="https://heptapod.host/saajns/procpath"
license=(LGPL3)
makedepends=(mercurial python-setuptools)
depends=(python python-jsonpyth python-pygal)
-source=("${pkgname}-${pkgver}::hg+${url}#revision=4e8ba95a83be")
+source=("${pkgname}::hg+${url}#revision=4e8ba95a83be")
sha512sums=('SKIP')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
python setup.py build
}
# tests are disabled for now due to https://heptapod.host/saajns/procpath/-/issues/21
#check() {
-# cd "${pkgname}-${pkgver}"
+# cd "${pkgname}"
#
-# python3 -m unittest
+# python -m unittest
#}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}