summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Garillot2017-02-24 13:13:10 -0500
committerFrançois Garillot2017-02-24 13:13:30 -0500
commitb324c05790b046ed5ba62d24d9109a7076110989 (patch)
tree94bf78d3f3a47950ea0503fbd3afeae4c663c67f
downloadaur-b324c05790b046ed5ba62d24d9109a7076110989.tar.gz
Initial version
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD61
-rw-r--r--install14
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f66c0ae6002d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Fri Feb 24 18:13:04 UTC 2017
+pkgbase = procps-ng-static
+ pkgdesc = Static lib for procps
+ pkgver = 3.3.11
+ pkgrel = 1
+ url = http://gitorious.org/procps
+ install = install
+ arch = i686
+ arch = x86_64
+ groups = base
+ license = GPL
+ license = LGPL
+ makedepends = ncurses
+ makedepends = systemd
+ provides = procps
+ provides = sysvinit-tools
+ provides = procps-ng
+ conflicts = procps
+ conflicts = sysvinit-tools
+ conflicts = procps-ng
+ conflicts = procps-ng-classic
+ replaces = procps
+ replaces = sysvinit-tools
+ options = !libtool
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-3.3.11.tar.xz
+ sha256sums = e9493169a2d2adc0bc045538707310c8e877b385e4e296143b62607d2bb044ed
+
+pkgname = procps-ng-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..663cf7865af1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: François Garillot <garillot.net: francois>
+# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: Gaetan Bisson <archlinux.org: bisson>
+# Contributor: Eric Bélanger <archlinux.org: eric>
+
+_pkgname=procps-ng
+pkgname=procps-ng-static
+pkgver=3.3.11
+pkgrel=1
+pkgdesc='Static lib for procps'
+url='http://gitorious.org/procps'
+license=('GPL' 'LGPL')
+arch=('i686' 'x86_64')
+groups=('base')
+makedepends=('ncurses' 'systemd')
+
+source=("http://downloads.sourceforge.net/project/${_pkgname}/Production/${_pkgname}-${pkgver}.tar.xz")
+sha256sums=('e9493169a2d2adc0bc045538707310c8e877b385e4e296143b62607d2bb044ed')
+options=('!libtool' 'staticlibs')
+
+groups=('base')
+
+conflicts=('procps' 'sysvinit-tools' 'procps-ng' 'procps-ng-classic')
+provides=('procps' 'sysvinit-tools' 'procps-ng')
+replaces=('procps' 'sysvinit-tools')
+
+install=install
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ sed 's:<ncursesw/:<:g' -i watch.c
+}
+
+build() {
+ cd "${srcdir}/procps-ng-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/ \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --enable-watch8bit \
+ --enable-static \
+ --with-systemd
+
+ make
+}
+
+package() {
+ cd "${srcdir}/procps-ng-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/lib/"
+ cp proc/.libs/libprocps.a "${pkgdir}/usr/lib/"
+ make DESTDIR="${pkgdir}" install
+
+ # provided by util-linux
+ rm "${pkgdir}/usr/bin/kill"
+ rm "${pkgdir}/usr/share/man/man1/kill.1"
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..2e6546ecc2a5
--- /dev/null
+++ b/install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ if [[ $(vercmp $2 3.3.8-3) = -1 ]]; then
+ cat <<EOF
+
+==> The file /etc/sysctl.conf has been removed from this
+==> package, as all its settings are now kernel defaults.
+
+==> If you had customized it, you need to rename it as
+==> /etc/sysctl.d/99-sysctl.conf since from version 207 on
+==> systemd only applies settings from /etc/sysctl.d/* .
+
+EOF
+ fi
+}