summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McCurry2016-11-28 13:53:25 -0500
committerDan McCurry2016-11-28 13:53:25 -0500
commitdf5b4242c44a7550e5173e3cb8812c9e2acdbf46 (patch)
tree189afc3fed424dd706af73110707549636b18ef2
downloadaur-df5b4242c44a7550e5173e3cb8812c9e2acdbf46.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
-rw-r--r--profex.desktop10
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dba0078a0181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = profex
+ pkgdesc = Open source XRD and Rietveld refinement.
+ pkgver = 3.10.2
+ pkgrel = 1
+ url = http://profex.doebelin.org
+ arch = i686
+ arch = x86_64
+ groups = science
+ license = GPL2
+ depends = bgmn
+ depends = qt5-declarative
+ depends = qt5-svg
+ depends = gcc-libs-multilib
+ provides = profex
+ conflicts = profex
+ source = http://profex.doebelin.org/wp-content/uploads/2016/10/profex-3.10.2.tar.gz
+ source = local://profex.desktop
+ md5sums = b5308154260ef9f6f811f9d072a8d28a
+ md5sums = d67ab02738497d00e200af6ee572d92b
+
+pkgname = profex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dc3038242fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+pkgname=profex
+pkgver=3.10.2
+pkgrel=1
+pkgdesc="Open source XRD and Rietveld refinement."
+arch=('i686' 'x86_64')
+url="http://profex.doebelin.org"
+license=('GPL2')
+groups=('science')
+depends=('bgmn'
+ 'qt5-declarative'
+ 'qt5-svg')
+optdepends=()
+provides=('profex')
+conflicts=('profex')
+source=("$url/wp-content/uploads/2016/10/${pkgname}-${pkgver}.tar.gz"
+ "local://profex.desktop")
+md5sums=('b5308154260ef9f6f811f9d072a8d28a'
+ 'd67ab02738497d00e200af6ee572d92b')
+case $CARCH in
+ i686) depends+=('gcc-libs');
+ ;;
+ x86_64) depends+=('gcc-libs-multilib');
+ ;;
+ *) error "Unsupported architecture.";
+ ;;
+esac
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake PREFIX=${pkgdir}/usr profex.pro
+ make -j 4
+}
+
+package() {
+ cd ${srcdir}
+ install -Dm644 "${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ cd "$pkgname-$pkgver"
+ install -Dm644 "src/icons/${pkgname}.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ make install
+
+ install -Dm755 "src/profex" "${pkgdir}/usr/bin/profex"
+}
diff --git a/profex.desktop b/profex.desktop
new file mode 100644
index 000000000000..d031f5018130
--- /dev/null
+++ b/profex.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Profex
+Comment=Open source XRD and Rietveld refinement.
+Exec=profex
+Icon=profex
+Terminal=false
+StartupNotify=false
+Categories=Application;Education;