summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 18:02:33 -0400
committergraysky2015-06-08 18:02:33 -0400
commit8392e0f448f423b910093bd1108ba2c215e78087 (patch)
tree83eb24cb89f67f35fbd591dd3b885e49000cd144
downloadaur-8392e0f448f423b910093bd1108ba2c215e78087.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--readme.install10
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6efa169d630c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = profile-cleaner
+ pkgdesc = Reduces profile size by cleaning their sqlite databases.
+ pkgver = 2.34
+ pkgrel = 1
+ url = https://github.com/graysky2/profile-cleaner
+ install = readme.install
+ arch = any
+ license = MIT
+ depends = bc
+ depends = parallel
+ depends = sqlite
+ source = http://repo-ck.com/source/profile-cleaner/profile-cleaner-2.34.tar.xz
+ sha256sums = 840001094760e69c891f2ccc82605b8caca4e637e794552149b25930c64de42d
+
+pkgname = profile-cleaner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c5f9b662a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname='profile-cleaner'
+pkgver=2.34
+pkgrel=1
+pkgdesc='Reduces profile size by cleaning their sqlite databases.'
+arch=('any')
+url='https://github.com/graysky2/profile-cleaner'
+license=('MIT')
+depends=('bc' 'parallel' 'sqlite')
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+install=readme.install
+sha256sums=('840001094760e69c891f2ccc82605b8caca4e637e794552149b25930c64de42d')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..24c29dc9c028
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo '--------------------------------------------------------------------------'
+ echo ' Make sure that target browsers or email clients are not running when'
+ echo ' invoking profile-cleaner. Failure to do so will result in the open files'
+ echo ' NOT getting cleaned and reindexed.'
+ echo
+ echo ' $HOME/.config/profile-cleaner.conf will be created when the script is'
+ echo ' called to run the first time. Edit it to select a color scheme.'
+ echo '--------------------------------------------------------------------------'
+}