summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-09-07 17:32:00 -0400
committergraysky2015-09-07 17:32:00 -0400
commit8809911a14d7dccd948d182a0be50a0038b7b174 (patch)
treebfba45969b2672ba05e41c6a9eac13ada728ec6d
parent04b798740a6cbae5d265e3e8ebfe9a6043385756 (diff)
downloadaur-8809911a14d7dccd948d182a0be50a0038b7b174.tar.gz
Update to 6.02-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--psd.install8
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d6f0b8b4427..8ff135de87a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = profile-sync-daemon
pkgdesc = Syncs browser profiles to tmpfs reducing SSD/HDD calls and speeding-up browsers.
pkgver = 6.02
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/graysky2/profile-sync-daemon
install = psd.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4374e78ef022..b6d2adfa077a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='profile-sync-daemon'
pkgver=6.02
-pkgrel=1
+pkgrel=2
pkgdesc='Syncs browser profiles to tmpfs reducing SSD/HDD calls and speeding-up browsers.'
arch=('any')
url='https://github.com/graysky2/profile-sync-daemon'
diff --git a/psd.install b/psd.install
index 3f9b296e538a..a2f6a6d0b786 100644
--- a/psd.install
+++ b/psd.install
@@ -28,9 +28,9 @@ pre_upgrade() {
# required that pacman stop the user service here if running
if [ $(vercmp $2 6.01) -lt 0 ]; then
for i in $(users); do
- running="$(su $i -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user is-active psd')"
+ running="$(su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user is-active psd')"
if [[ "$running" = "active" ]]; then
- su $i -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user stop psd.service'
+ su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user stop psd.service'
echo '-> Internal changes to psd require it to be stopped now before updating.'
echo '-> Recommend that you diff /usr/share/doc/psd/psd.conf against ~/.psd/psd.conf'
fi
@@ -40,11 +40,11 @@ pre_upgrade() {
pre_remove() {
for i in $(users); do
- running="$(su $i -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user is-active psd')"
+ running="$(su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user is-active psd')"
if [[ "$running" = "active" ]]; then
echo "--> In order to preserve your profiles, pacman will now stop your psd service."
echo "--> Any running and managed browsers will be exited."
- su $i -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user stop psd.service'
+ su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user stop psd.service'
fi
done
}