summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-10-27 01:10:53 -0400
committergraysky2015-10-27 01:10:53 -0400
commit77bb77aa22315b0d7611944859480ac8a4384768 (patch)
treed939d482078ed5aa0eaba9210be70b898e2b066f
parentec4135896d9ad437602a14bf84fc5b67ca016ab7 (diff)
downloadaur-77bb77aa22315b0d7611944859480ac8a4384768.tar.gz
Update to r603.d103baf-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--psd.install32
3 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3260fb14f090..1412d3357087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = profile-sync-daemon-git
pkgdesc = Syncs browser profiles to tmpfs. Unstable git version!
- pkgver = 6.12.r7.gd103baf.unstable
+ pkgver = r603.d103baf
pkgrel = 1
url = https://github.com/graysky2/profile-sync-daemon
install = psd.install
diff --git a/PKGBUILD b/PKGBUILD
index ffbbbe07c792..39bee2023193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='profile-sync-daemon-git'
_pkgname='profile-sync-daemon'
-pkgver=6.12.r7.gd103baf.unstable
+pkgver=r603.d103baf
pkgrel=1
pkgdesc='Syncs browser profiles to tmpfs. Unstable git version!'
arch=('any')
@@ -21,7 +21,8 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- echo $(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g').$_branch
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #echo $(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g').$_branch
}
prepare() {
diff --git a/psd.install b/psd.install
index baa1b3efd221..6f20951a6064 100644
--- a/psd.install
+++ b/psd.install
@@ -2,37 +2,19 @@
## arg 2: the old package version
users=$(loginctl --no-legend list-users | awk '{ print $2 }' | sed ':a;N;$!ba;s/\n/ /g')
-post_install() {
- echo '--> WARNING! DEVELOPMENT VERSION!'
- echo '--> ALWAYS backup your profile data before using utils like psd!'
+post_upgrade() {
for i in $users; do
su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user daemon-reload'
done
}
-pre_upgrade() {
- # version 6.00 is a major rebuild
- # yes, I realize that pacman should not stop services byt in this case it
- # is required or else browser profiles (user data) can get renamed and confuse
- # people if it does not happen
- if [ $(vercmp $2 6.00) -lt 0 ]; then
- echo 'ATTENTION: MAJOR CHANGES TO PSD WITH VERSION 6.00+'
- echo '-> 1. A global /etc/psd.conf is no longer used. $HOME/.psd/psd.conf will be'
- echo '-> created when psd is invoked the first time.'
- echo '-> 2. A system service is no longer used. A user service is provided and can be'
- echo '-> used like this: systemctl --user start psd.service'
- echo '-> 3. Users wanting to use overlayfs mode MUST have sudo access to both mount'
- echo '-> and umount. See the man page for an example configured with visudo.'
- echo
- echo '-> Internal changes to psd require it to be stopped now before updating.'
-
- # stop system service now since it will be removed upon updating
- systemctl is-active psd.service &>/dev/null
- if [ $? -eq 0 ]; then
- systemctl stop psd.service &>/dev/null
- fi
- fi
+post_install() {
+ echo '--> WARNING! DEVELOPMENT VERSION!'
+ echo '--> ALWAYS backup your profile data before using utils like psd!'
+ post_upgrade
+}
+pre_upgrade() {
# in general stop and restart always when using dev version
for i in $users; do
running="$(su $i -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user is-active psd')"