summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 18:02:51 -0400
committergraysky2015-06-08 18:02:51 -0400
commitfc09ad80486b244f36dd2bd126f384a93ba30e62 (patch)
tree98ccc8df248d9317a417d8ae7d5b14d6de6a1e7e
downloadaur-fc09ad80486b244f36dd2bd126f384a93ba30e62.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
-rw-r--r--psd.install24
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7f17673f4e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = profile-sync-daemon-git
+ pkgdesc = Syncs browser profiles to tmpfs. Unstable git version!
+ pkgver = 5.68.r3.gd8188fc.unstable
+ pkgrel = 1
+ url = https://github.com/graysky2/profile-sync-daemon
+ install = psd.install
+ arch = any
+ license = MIT
+ depends = procps-ng
+ depends = rsync
+ provides = profile-sync-daemon
+ conflicts = firefox-sync
+ conflicts = goanysync
+ conflicts = go-anysync-git
+ conflicts = iceweasel-sync
+ conflicts = tmpfs-store
+ conflicts = tmpfs-sync
+ conflicts = user-profile-sync-daemon
+ conflicts = profile-sync-daemon
+ backup = etc/psd.conf
+ source = git://github.com/graysky2/profile-sync-daemon#branch=unstable
+ sha256sums = SKIP
+
+pkgname = profile-sync-daemon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bad7b693da1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname='profile-sync-daemon-git'
+_pkgname='profile-sync-daemon'
+pkgver=5.68.r3.gd8188fc.unstable
+pkgrel=1
+pkgdesc='Syncs browser profiles to tmpfs. Unstable git version!'
+arch=('any')
+url='https://github.com/graysky2/profile-sync-daemon'
+license=('MIT')
+depends=('procps-ng' 'rsync')
+conflicts=('firefox-sync' 'goanysync' 'go-anysync-git' 'iceweasel-sync'
+'tmpfs-store' 'tmpfs-sync' 'user-profile-sync-daemon' 'profile-sync-daemon')
+provides=('profile-sync-daemon')
+source=("git://github.com/graysky2/profile-sync-daemon#branch=unstable")
+backup=('etc/psd.conf')
+install=psd.install
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo $(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g').unstable
+ #echo $(git rev-parse --short unstable)
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # set version of psd to match pkgver
+ sed -i "s/@VERSION@/$pkgver/" "$srcdir/$_pkgname/common/profile-sync-daemon.in"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ # note if you want to use openrc rather than systemd, change the below make
+ # target to 'install-openrc-all' before building and be sure that you read
+ # the INSTALL document provided in the source tarball!
+ make DESTDIR="$pkgdir" install-systemd-all
+ install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/psd.install b/psd.install
new file mode 100644
index 000000000000..b9cbd46dbb74
--- /dev/null
+++ b/psd.install
@@ -0,0 +1,24 @@
+DAEMON_FILE="/run/psd"
+
+post_install() {
+ echo '--> WARNING! DEVELOPMENT VERSION!'
+ echo
+ echo '--> Define which users will make use of the sync in /etc/psd.conf'
+ echo '--> Read the manpage before use or see the wiki page'
+ echo '--> https://wiki.archlinux.org/index.php/Profile-sync-daemon'
+ echo
+ echo '--> ALWAYS backup your profile data before using utils like psd!'
+}
+
+
+pre_remove() {
+ if [ -e $DAEMON_FILE ]; then
+ if ! systemd-notify --booted; then # not using systemd
+ echo '--> Automatically stopping psd to rotate profiles back out of tmpfs.'
+ /etc/rc.d/psd stop
+ else
+ echo '--> Automatically stopping psd to rotate profiles back out of tmpfs.'
+ /usr/bin/systemctl stop psd.service
+ fi
+ fi
+}