summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgudzpoz2023-08-12 17:13:44 +0800
committergudzpoz2023-08-12 17:13:44 +0800
commitb4de9eaa95160462bcb8b626790b80eef707fa31 (patch)
tree8fc4856be3253759489d622dd9e9142c38cd3352
downloadaur-b4de9eaa95160462bcb8b626790b80eef707fa31.tar.gz
Adapt config from that of firefox
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--thunderbird18
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdf9113c655e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = profile-sync-daemon-thunderbird
+ pkgdesc = Thunderbird support for profile-sync-daemon
+ pkgver = 2023.08.12
+ pkgrel = 1
+ url = https://github.com/graysky2/profile-sync-daemon/blob/master/common/browsers/firefox
+ arch = any
+ license = MIT
+ depends = profile-sync-daemon
+ optdepends = thunderbird: the target browser
+ source = thunderbird
+ sha256sums = 3d38c6cf12865b189f562e6919efc7e905008099ad10a92096d3a9068269568e
+
+pkgname = profile-sync-daemon-thunderbird
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61cf6c349209
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: gudzpoz <gudzpoz@live.com>
+
+pkgname=profile-sync-daemon-thunderbird
+pkgver=2023.08.12
+pkgrel=1
+pkgdesc="Thunderbird support for profile-sync-daemon"
+url="https://github.com/graysky2/profile-sync-daemon/blob/master/common/browsers/firefox"
+arch=('any')
+license=('MIT')
+depends=('profile-sync-daemon')
+optdepends=(
+ 'thunderbird: the target browser'
+)
+source=("thunderbird")
+sha256sums=('3d38c6cf12865b189f562e6919efc7e905008099ad10a92096d3a9068269568e')
+
+package() {
+ install -Dm644 thunderbird "${pkgdir}/usr/share/psd/browsers/thunderbird"
+}
diff --git a/thunderbird b/thunderbird
new file mode 100644
index 000000000000..0877d3ae6826
--- /dev/null
+++ b/thunderbird
@@ -0,0 +1,18 @@
+if [[ -d "$HOME"/.thunderbird ]]; then
+ index=0
+ PSNAME="$browser"
+ while read -r profileItem; do
+ if [[ $(echo "$profileItem" | cut -c1) = "/" ]]; then
+ # path is not relative
+ DIRArr[$index]="$profileItem"
+ else
+ # we need to append the default path to give a
+ # fully qualified path
+ DIRArr[$index]="$HOME/.thunderbird/$profileItem"
+ fi
+ (( index=index+1 ))
+ done < <(grep '[Pp]'ath= "$HOME"/.thunderbird/profiles.ini | sed 's/[Pp]ath=//')
+fi
+
+check_suffix=1
+