summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2016-08-11 21:36:08 +0200
committerWilliam Gathoye2016-08-11 21:36:23 +0200
commita8ce80b217341c25a506732dd0a38c4d04d00718 (patch)
tree3129566c4f1b443c6d6bc2b7f6f2ae738eb4faee
parent20c9796d9b1e61c62cb62f4479e00a6c607684a6 (diff)
downloadaur-a8ce80b217341c25a506732dd0a38c4d04d00718.tar.gz
Fix spaces, remind the install location even after updates, check if directory empty when removing
-rw-r--r--PKGBUILD6
-rw-r--r--progit2-git.install16
2 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70a8c0c1953a..797d8beec8dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=progit2-git
pkgver=2.0.0.r611.g024a3a0
-pkgrel=1
+pkgrel=2
pkgdesc="A package to build the latest version of the progit2 book and read it when offline"
arch=('any')
@@ -28,7 +28,7 @@ pkgver() {
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
# Gem dependencies can be installed per user and not systemwide in
# /home/<your username>/.gem/ruby/<ruby version>/, but we won't be able to
@@ -58,7 +58,7 @@ prepare() {
package() {
# When entering here, we are in the src directory, go in the cloned progit2
# directory.
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
bundle exec rake book:build
diff --git a/progit2-git.install b/progit2-git.install
index 8202977471d5..ae37c700c276 100644
--- a/progit2-git.install
+++ b/progit2-git.install
@@ -1,9 +1,17 @@
# arg 1: the new package version
+post_install() {
+ echo "==> The progit2 book has been installed to /usr/share/doc/progit2/"
+}
+
+# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
+ echo "==> The progit2 book has been updated and is located in /usr/share/doc/progit2/"
+}
- cat << EOF
-==> The progit2 book has been installed to /usr/share/doc/progit2/
-EOF
-
+# arg 1: the old package version
+post_remove() {
+ if [ -d "/usr/share/doc/progit2" ]; then
+ echo "==> The directory "/usr/share/doc/progit2" has not been removed because it wasn't (maybe) empty. Check that out."
+ fi
}