summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVíctor Castillo2021-04-11 21:47:25 +0200
committerVíctor Castillo2021-04-11 21:47:25 +0200
commit67c86933d24f1ba6b0696a5c20697bd5eb9a47b9 (patch)
tree57357c063145238a07260fa958542594fb091205
downloadaur-67c86933d24f1ba6b0696a5c20697bd5eb9a47b9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebb88bf3e551
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = program-shell-git
+ pkgver = r6.55cd858
+ pkgrel = 1
+ url = https://github.com/castillo055/program-shell/
+ arch = any
+ license = unknown
+ makedepends = git
+ makedepends = cmake
+ provides = program-shell
+ conflicts = program-shell
+ source = git+https://github.com/castillo055/program-shell#branch=main
+ md5sums = SKIP
+
+pkgname = program-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daa47a309771
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: castillo055
+pkgname=program-shell-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r6.55cd858
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/castillo055/program-shell/"
+license=('unknown')
+groups=()
+depends=()
+makedepends=('git'
+ 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=()
+options=()
+install=
+source=('git+https://github.com/castillo055/program-shell#branch=main')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake .
+ cmake --build . --target program_shell
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake --install . --target program_shell --prefix "$pkgdir/usr/"
+}