summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-24 15:14:30 +0300
committerCaleb Maclennan2020-02-25 10:14:30 +0300
commit868155ba48a8b8315c1995d345130aad32a2a89a (patch)
tree036556032b17ff078f615e2c5897310ccc0a98eb
parent3ea2884f4ee4711c4218c4e168ab780398fc720f (diff)
downloadaur-868155ba48a8b8315c1995d345130aad32a2a89a.tar.gz
Cleanup packaging
* Remove depends and makedependes that are required by base package which used to be an optional package group and is now a required meta package. Since it's impossible to have a (supported) Arch system without these they do not need to be called out. * Drop home directory installation related scripts. * Sanitize the install by not using upstream script which assumes directories exist, that we want to build as root, etc. * Mention myself as a maintainer.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD51
2 files changed, 36 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81b1c790dc92..5ada260994c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = programmers-dvorak
pkgdesc = Variant of the Dvorak keyboard layout designed for programmers
pkgver = 1.2
- pkgrel = 5
+ pkgrel = 6
url = http://www.kaufmann.no/roland/dvorak/
install = programmers-dvorak.install
arch = any
license = custom
- makedepends = coreutils
- depends = kbd
depends = libxslt
- noextract = http://www.kaufmann.no/downloads/linux/dvp-1_2_1.map.gz
+ noextract = dvp-1_2_1.map.gz
source = http://www.kaufmann.no/downloads/linux/kbddvp-1_2_1-src-linux.tgz
source = http://www.kaufmann.no/downloads/linux/dvp-1_2_1.map.gz
source = LICENSE
- md5sums = 6d7797f1514be62cb01fbdf3a7e785a4
- md5sums = 8cde9c8f6b4de6c7c2ebb27589a5116e
- md5sums = 48ebb9016f6138334194103caba4483f
+ sha256sums = 0f56b55432d63a6d81c08ff5f722cf48c6d9a15c34c304f594d02eb2223fc4fa
+ sha256sums = 0e859211cfe16a18a3b9cbf2ca3e280a23a79b4e40b60d8d01d0fde7336b6d50
+ sha256sums = 123675c594fe0349a7c27b124cf03715d293af60047d1916c657ac25d0f86ce8
pkgname = programmers-dvorak
diff --git a/PKGBUILD b/PKGBUILD
index 30dd2354a8d5..9da60eae6ff6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,43 @@
# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: AndreasBWagner <AndreasBWagner@pointfree.net>
# Contributor: Mark Taylor <skymt0@gmail.com>
+
pkgname=programmers-dvorak
pkgver=1.2
-pkgrel=5
-pkgdesc="Variant of the Dvorak keyboard layout designed for programmers"
+_linuxrel=1
+_pkgver=${pkgver//./_}_$_linuxrel
+pkgrel=6
+pkgdesc='Variant of the Dvorak keyboard layout designed for programmers'
arch=(any)
-url="http://www.kaufmann.no/roland/dvorak/"
+url='http://www.kaufmann.no/roland/dvorak/'
license=('custom')
install=programmers-dvorak.install
-depends=('kbd' 'libxslt')
-makedepends=('coreutils')
-source=("http://www.kaufmann.no/downloads/linux/kbddvp-1_2_1-src-linux.tgz"
- "http://www.kaufmann.no/downloads/linux/dvp-1_2_1.map.gz"
- "LICENSE")
-noextract=("http://www.kaufmann.no/downloads/linux/dvp-1_2_1.map.gz")
-md5sums=('6d7797f1514be62cb01fbdf3a7e785a4'
- '8cde9c8f6b4de6c7c2ebb27589a5116e'
- '48ebb9016f6138334194103caba4483f')
+depends=('libxslt')
+source=("http://www.kaufmann.no/downloads/linux/kbddvp-$_pkgver-src-linux.tgz"
+ "http://www.kaufmann.no/downloads/linux/dvp-$_pkgver.map.gz"
+ 'LICENSE')
+noextract=("${source[1]##*/}")
+sha256sums=('0f56b55432d63a6d81c08ff5f722cf48c6d9a15c34c304f594d02eb2223fc4fa'
+ '0e859211cfe16a18a3b9cbf2ca3e280a23a79b4e40b60d8d01d0fde7336b6d50'
+ '123675c594fe0349a7c27b124cf03715d293af60047d1916c657ac25d0f86ce8')
+
+prepare() {
+ cd "kbddvp-$pkgver"
+ # Upstream install script makes too many assumptions about the host system:
+ # directories existing, being root, etc. We'll make our own way...
+ rm dvp.install.sh
+}
package() {
- cd $srcdir/kbddvp-$pkgver
- mkdir -p $pkgdir/usr/share/X11/xkb/{symbols,types}
- chmod +x *.sh
- ./dvp.install.sh $pkgdir/usr/share/X11/xkb
- mkdir -p $pkgdir/usr/share/$pkgname
- install -Dm644 $srcdir/dvp-1_2_1.map.gz $pkgdir/usr/share/kbd/keymaps/i386/dvorak/dvp.map.gz
- install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -Dm755 *.sh $pkgdir/usr/share/$pkgname
+ cd "kbddvp-$pkgver"
+ install -Dm755 -t "$pkgdir/usr/share/$pkgname/" dvp.*.sh
+ install -Dm644 "../${source[1]##*/}" "$pkgdir/usr/share/kbd/keymaps/i386/dvorak/dvp.map.gz"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "../${source[2]}"
+ # Adapt relevant system installation bits from dvp.install.sh...
+ for f in dvp hex atm 102 ops semi; do
+ install -Dm644 $f.xkb "$pkgdir/usr/share/X11/xkb/symbols/$f"
+ done
+ install -Dm644 shift3.xkb "$pkgdir/usr/share/X11/xkb/types/shift3"
}