summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXunhua Guo2023-08-20 19:24:24 +0800
committerXunhua Guo2023-08-20 19:24:24 +0800
commit03b975ecd61156654dc713586bd15af90d8cf7c4 (patch)
tree6b70af7a74196173b30e4037bb60efef8ddab87d
parente7dfb44cd29fb0b4f8122268218098edc8d1e969 (diff)
downloadaur-03b975ecd61156654dc713586bd15af90d8cf7c4.tar.gz
updated to 0.9.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--array.patch11
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5898e6664ce..9d34346ecaa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = projecteur
pkgdesc = Linux Desktop Application for the Logitech Spotlight device.
- pkgver = 0.9.1
+ pkgver = 0.9.2
pkgrel = 1
url = https://github.com/jahnf/Projecteur
install = projecteur.install
@@ -12,10 +12,11 @@ pkgbase = projecteur
depends = udev
provides = projecteur
conflicts = projecteur-git
- source = https://github.com/jahnf/Projecteur/releases/download/v0.9.1/projecteur-0.9.1_source.tar.gz
+ source = https://github.com/jahnf/Projecteur/releases/download/v0.9.2/projecteur-0.9.2_source.tar.gz
source = projecteur.install
- sha256sums = cbdcad61b391438033f33bf6f52ff80a1c772ff5e23704950917361784ca0707
+ source = array.patch
+ sha256sums = 2924f5f4ec5deb41a523292e2207e4d298c17bd70e855897dfdafe3b15a01c9d
sha256sums = a8d406a61d84834358aba36718547be20eb6ee1d055c4ffdb28fe9f56d22aaaf
+ sha256sums = c58eedbee9d61d18309e90d0a97d6d4ef49ecb4f1e2c554218215f8bae6c2fde
pkgname = projecteur
-
diff --git a/PKGBUILD b/PKGBUILD
index 4ecd0f203ff6..a2c0d064c1ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# vim: set ts=8 sw=8 expandtab:
-#
-# Maintainer: m4dz <code@m4dz.net>
+# Maintainer: Xunhua Guo <xunhua.guo@gmail.com>
+# Contributer: m4dz <code@m4dz.net>
+
pkgname=projecteur
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=1
pkgdesc="Linux Desktop Application for the Logitech Spotlight device."
arch=('x86_64')
@@ -14,11 +14,15 @@ makedepends=('cmake' 'make')
provides=('projecteur')
conflicts=('projecteur-git')
source=("https://github.com/jahnf/Projecteur/releases/download/v${pkgver}/projecteur-${pkgver}_source.tar.gz"
- "projecteur.install")
-sha256sums=('cbdcad61b391438033f33bf6f52ff80a1c772ff5e23704950917361784ca0707'
- 'a8d406a61d84834358aba36718547be20eb6ee1d055c4ffdb28fe9f56d22aaaf')
+ "projecteur.install"
+ "array.patch")
+sha256sums=('2924f5f4ec5deb41a523292e2207e4d298c17bd70e855897dfdafe3b15a01c9d'
+ 'a8d406a61d84834358aba36718547be20eb6ee1d055c4ffdb28fe9f56d22aaaf'
+ 'c58eedbee9d61d18309e90d0a97d6d4ef49ecb4f1e2c554218215f8bae6c2fde')
prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/array.patch"
mkdir -p "$srcdir/build"
cd "$srcdir/build"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr "$srcdir/$pkgname-$pkgver"
diff --git a/array.patch b/array.patch
new file mode 100644
index 000000000000..fd52d28340c4
--- /dev/null
+++ b/array.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text projecteur-0.9.2_orig/src/device.h projecteur-0.9.2/src/device.h
+--- projecteur-0.9.2_orig/src/device.h 2023-08-20 18:15:44.009596913 +0800
++++ projecteur-0.9.2/src/device.h 2023-08-20 18:30:38.419496407 +0800
+@@ -4,6 +4,7 @@
+ #include "enum-helper.h"
+
+ #include <memory>
++#include <array>
+
+ #include <QObject>
+