summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2021-08-24 10:48:46 +0200
committerRicardo (XenGi) Band2021-08-24 10:48:46 +0200
commite969ed9e260470ae04155cc07cf4e7831c0e38f8 (patch)
treed07c8e4190214788e125165fec01693209766bbb
downloadaur-e969ed9e260470ae04155cc07cf4e7831c0e38f8.tar.gz
initial package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD45
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16ff2e5fc8e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = projen
+ pkgdesc = Define and maintain complex project configuration through code
+ pkgver = 0.27.32
+ pkgrel = 1
+ url = https://github.com/projen/projen/
+ arch = any
+ license = Apache
+ makedepends = npm
+ makedepends = jq
+ depends = nodejs
+ optdepends = bash-completion: Bash completion
+ noextract = projen-0.27.32.tgz
+ source = https://registry.npmjs.org/projen/-/projen-0.27.32.tgz
+ sha256sums = 7021b484a710a0b99e1e4d1b46c1139cc2fd8553d36b445c988fc204842bae5b
+
+pkgname = projen
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2e7a976b538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: email@ricardo.band
+
+pkgname=projen
+pkgver=0.27.32
+pkgrel=1
+pkgdesc="Define and maintain complex project configuration through code"
+arch=('any')
+url="https://github.com/projen/projen/"
+license=('Apache')
+depends=('nodejs')
+makedepends=('npm' 'jq')
+optdepends=('bash-completion: Bash completion')
+source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+noextract=("${pkgname}-${pkgver}.tgz")
+sha256sums=('7021b484a710a0b99e1e4d1b46c1139cc2fd8553d36b445c988fc204842bae5b')
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/cli/issues/1103 for details.
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ # Remove references to $pkgdir
+ find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
+
+ # Remove references to $srcdir
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
+
+ find "$pkgdir" -type f -name package.json | while read pkgjson; do
+ local tmppackage="$(mktemp)"
+ jq 'del(.man)' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
+ done
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}
+