summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2018-03-19 11:36:14 +0100
committerNils Czernia2018-03-19 11:36:14 +0100
commitde0eaa0572df2a26d8a5f880d489598679739c84 (patch)
tree94c4c64a840b6c4d6abd63f6c2d0354d4d2558c3
downloadaur-de0eaa0572df2a26d8a5f880d489598679739c84.tar.gz
Inital commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
-rw-r--r--prometheus-push-gateway.service9
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79e28eaff1d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Mar 19 10:35:38 UTC 2018
+pkgbase = prometheus-push-gateway-bin
+ pkgdesc = Prometheus push acceptor for ephemeral and batch jobs
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/prometheus/pushgateway
+ arch = x86_64
+ license = Apache
+ source = https://github.com/prometheus/pushgateway/releases/download/v0.4.0/pushgateway-0.4.0.linux-amd64.tar.gz
+ source = prometheus-push-gateway.service
+ sha256sums = e1ce58b3f2c44816e748278434d6fc91e530da77dcc34b1246e1a0f25314831f
+ sha256sums = fe0ec9b3f18f2f35177fdf8dd8bd5ef0cee3189b65051b4239ad2ba1f5e9961c
+
+pkgname = prometheus-push-gateway-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fde441386882
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
+!prometheus-push-gateway.service
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb75eea48c79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nils Czernia <nils@czserver.de>
+
+pkgname=prometheus-push-gateway-bin
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Prometheus push acceptor for ephemeral and batch jobs "
+arch=('x86_64')
+url="https://github.com/prometheus/pushgateway"
+license=('Apache')
+makedepends=()
+source=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-amd64.tar.gz"
+ "prometheus-push-gateway.service")
+sha256sums=('e1ce58b3f2c44816e748278434d6fc91e530da77dcc34b1246e1a0f25314831f'
+ 'fe0ec9b3f18f2f35177fdf8dd8bd5ef0cee3189b65051b4239ad2ba1f5e9961c')
+
+package() {
+ install -Dm755 "${srcdir}/pushgateway-${pkgver}.linux-amd64/pushgateway" "${pkgdir}/usr/bin/prometheus-push-gateway"
+ install -Dm755 "${srcdir}/prometheus-push-gateway.service" "${pkgdir}/usr/lib/systemd/system/prometheus-push-gateway.service"
+}
diff --git a/prometheus-push-gateway.service b/prometheus-push-gateway.service
new file mode 100644
index 000000000000..8acc0c3558ea
--- /dev/null
+++ b/prometheus-push-gateway.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Prometheus exporter for PostgreSQL
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/prometheus-push-gateway
+
+[Install]
+WantedBy=multi-user.target