summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2015-06-13 15:41:15 +0430
committerBehnam Momeni2015-06-13 15:47:33 +0430
commit841f1bb5cfcd545d3d706cd80defb0bfc7242b76 (patch)
tree7f07489b2c4572f4c3e66d48d95d01633c9a5fa9
downloadaur-841f1bb5cfcd545d3d706cd80defb0bfc7242b76.tar.gz
Migrating pronounce-git package to AUR4
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..980f629bc379
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pronounce-git
+ pkgdesc = A command line interface for English words pronunciation
+ pkgver = v1.1.0.1.gd18cb7f
+ pkgrel = 1
+ url = https://github.com/momeni/pronounce
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = ffmpeg
+ depends = wget
+ depends = coreutils
+ optdepends = w3m: viewing definition of words in w3m; a CLI browser
+ optdepends = firefox: viewing definition of words in Mozilla Firefox
+ provides = pronounce
+ conflicts = pronounce
+ source = git+https://github.com/momeni/pronounce.git
+ sha256sums = SKIP
+
+pkgname = pronounce-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..543ae475a7ea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+pronounce/
+*.pkg.tar.xz
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e545653ded35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+
+pkgname=('pronounce-git')
+
+_gitname=pronounce
+#The actual value is calculated by pkgver() function
+pkgver=v1.1.0.1.gd18cb7f
+pkgrel=1
+
+pkgdesc="A command line interface for English words pronunciation"
+url="https://github.com/momeni/${_gitname}"
+
+arch=('any')
+license=('GPL3')
+
+depends=('ffmpeg' 'wget' 'coreutils')
+optdepends=(
+ 'w3m: viewing definition of words in w3m; a CLI browser'
+ 'firefox: viewing definition of words in Mozilla Firefox'
+)
+conflicts=('pronounce')
+provides=('pronounce')
+makedepends=('git')
+source=('git+https://github.com/momeni/pronounce.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -D -m 755 pronounce "${pkgdir}/usr/bin/pronounce"
+ install -D -m 644 README.md "${pkgdir}/usr/share/pronounce/README.md"
+}
+