summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheLoko2016-02-10 13:46:57 +0100
committerTheLoko2016-02-10 13:46:57 +0100
commitf2ffc544965200b21804c4578ea60c6fec82865f (patch)
tree68cc70b66cf1edd5db23c0947b9be089ce127cfd
downloadaur-f2ffc544965200b21804c4578ea60c6fec82865f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..911e70cf28e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 12:39:24 UTC 2016
+pkgbase = proot-bin
+ pkgdesc = chroot, mount --bind, and binfmt_misc without privilege/setup (bin only)
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = http://proot.me
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = talloc
+ provides = proot
+ conflicts = proot
+
+pkgname = proot-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85b3504e0393
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mantainer Julio Gonzalez <juliolokoo at gmail dot com>
+
+pkgname=proot-bin
+_pkgname=proot
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="chroot, mount --bind, and binfmt_misc without privilege/setup (bin only)"
+arch=('i686' 'x86_64')
+url="http://proot.me"
+license=('GPL')
+provides=('proot')
+conflicts=('proot')
+depends=('talloc')
+[ "$CARCH" = "i686" ] && source=("${_pkgname}"::'http://portable.proot.me/proot-x86_64')
+[ "$CARCH" = "x86_64" ] && source=("${_pkgname}"::'http://portable.proot.me/proot-x86_64')
+[ "$CARCH" = "i686" ] && sha1sums=('6b2f18ff13c1b7f1efe5b55dac0dadaa6966f7a1')
+[ "$CARCH" = "x86_64" ] && sha1sums=('5e713559fd336074971590e8cbe7ab1593ffabfc')
+
+package() {
+ install -dm755 "${pkgdir}"/usr/bin
+ install -m755 ${srcdir}/${_pkgname} "${pkgdir}"/usr/bin
+}
+
+# vim: ft=sh syn=sh et