summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 11:02:43 -0700
committerMark Wagie2024-01-21 11:02:43 -0700
commit9cd2069651321173ad9e400ac6891810cdaf1de6 (patch)
tree01a0abc1c0d0888abfe25548c28f3e01f09f5f5c
parent3773ce985fd65665b450928e68e82e1a573eb3db (diff)
downloadaur-9cd2069651321173ad9e400ac6891810cdaf1de6.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d65304373b1c..ceeff681dd88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = proot-termux
pkgrel = 1
url = https://github.com/termux/proot
arch = x86_64
- license = GPL
+ license = GPL-2.0-or-later
checkdepends = valgrind
makedepends = git
depends = talloc
diff --git a/PKGBUILD b/PKGBUILD
index 156602257659..e126c45ab77b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=proot-termux
pkgver=r187.5c462a6
pkgrel=1
pkgdesc="A copy of the PRoot project with patches applied to work better under Termux."
arch=('x86_64')
url="https://github.com/termux/proot"
-license=('GPL')
+license=('GPL-2.0-or-later')
depends=('talloc')
makedepends=('git')
checkdepends=('valgrind')
@@ -16,19 +16,19 @@ source=("git+https://github.com/termux/proot.git#commit=${_commit}")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/proot"
+ cd proot
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/proot"
+ cd proot
make -C src
}
# Tests seem to go on perpetually
#check() {
-# cd "$srcdir/proot"
+# cd proot
# env LD_SHOW_AUXV=1 true
# cat /proc/cpuinfo
# ./src/proot -V
@@ -37,7 +37,7 @@ build() {
#}
package() {
- cd "$srcdir/proot"
+ cd proot
make -C src install PREFIX="$pkgdir/usr"
install -Dm644 doc/proot/man.1 "$pkgdir/usr/share/man/man1/proot.1"