diff options
author | Phillip Davies | 2023-08-20 21:00:17 +1200 |
---|---|---|
committer | Phillip Davies | 2023-08-20 21:00:17 +1200 |
commit | e877433e262e17b82e450b184f6f735d1e5911f9 (patch) | |
tree | 79d3b4351e5e222cf616499cb478236b5270cda8 | |
parent | 972476f1d2d422468f82351502ab8a1989e9b9c8 (diff) | |
download | aur-e877433e262e17b82e450b184f6f735d1e5911f9.tar.gz |
Adopted pkg + using a venv to prevent conflicts
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 10 |
2 files changed, 8 insertions, 6 deletions
@@ -1,11 +1,11 @@ pkgbase = pros-cli pkgdesc = Command Line Interface for managing PROS projects. Works with V5 and the Cortex - pkgver = 3.2.2 + pkgver = 3.4.3 pkgrel = 1 url = https://github.com/purduesigbots/pros-cli arch = x86_64 license = MPL - depends = python-pip + depends = python-pipx depends = arm-none-eabi-newlib depends = arm-none-eabi-gcc @@ -1,13 +1,15 @@ -# Maintainer: Ian Lansdowne <idlansdowne at gmail dot com> +# Maintainer: Phillip Davies <philliptdavies at gmail dot com> pkgname=pros-cli -pkgver=3.2.2 +pkgver=3.4.3 pkgrel=1 pkgdesc="Command Line Interface for managing PROS projects. Works with V5 and the Cortex" arch=('x86_64') url="https://github.com/purduesigbots/pros-cli" license=('MPL') -depends=('python-pip' 'arm-none-eabi-newlib' 'arm-none-eabi-gcc') +depends=('python-pipx' 'arm-none-eabi-newlib' 'arm-none-eabi-gcc') package() { - PIP_CONFIG_FILE=/dev/null pip install --isolated --root=$pkgdir --ignore-installed --no-deps pros-cli==$pkgver + export PIPX_HOME="$pkgdir/usr/local" + export PIPX_BIN_DIR="$pkgdir/usr/bin" + pipx install pros-cli==$pkgver } |