summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-11-19 00:24:44 +0100
committerMaxime “pep” Buquet2019-11-19 00:36:23 +0100
commit724c75bdc1d799036a1381841cdf35ece2a7766d (patch)
tree2e368c3ad681a437b27f1f07f289cda644822da8
parent887149c3e11462642fb282d81b4a7e06fe7e030a (diff)
downloadaur-724c75bdc1d799036a1381841cdf35ece2a7766d.tar.gz
Use ICU instead of libidn as suggested by upstream
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f50cf157085..7345753b74fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,11 @@ pkgbase = prosody-hg
checkdepends = lua52-posix
checkdepends = lua52-sec
makedepends = mercurial
+ depends = icu
depends = lua52
depends = lua52-socket
depends = lua52-expat
depends = lua52-filesystem
- depends = libidn
depends = openssl
optdepends = lua52-sec: TLS encryption support
optdepends = lua52-bitop: websocket support
diff --git a/PKGBUILD b/PKGBUILD
index 0ca1c9b76f27..ccd10542ed2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,8 +18,13 @@ pkgdesc="Lightweight and extensible Jabber/XMPP server written in Lua (developme
arch=('i686' 'x86_64' 'armv7h')
url="https://prosody.im/"
license=('MIT')
-depends=('lua52' 'lua52-socket' 'lua52-expat' 'lua52-filesystem' 'libidn'
- 'openssl')
+depends=(
+ 'icu'
+ 'lua52'
+ 'lua52-socket'
+ 'lua52-expat'
+ 'lua52-filesystem'
+ 'openssl')
makedepends=('mercurial')
checkdepends=('luacheck' 'shellcheck' 'lua52-posix' 'lua52-sec')
conflicts=('prosody')
@@ -65,7 +70,8 @@ build() {
--cflags="${CFLAGS} -fPIC -Wall -Wextra -D_GNU_SOURCE" \
--ldflags="${LDFLAGS} -shared" --no-example-certs \
--runwith=lua5.2 \
- --lua-version=5.2
+ --lua-version=5.2 \
+ --idn-library=icu
make
}