summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-10-25 01:34:32 +0200
committerDavid Runge2017-10-25 01:34:32 +0200
commit3ed188b53f09c58172411a43cdb67cca7068a4ca (patch)
treeceb0ca48cbd523901b8f8b67164c4c03f1c5565c
parentfcb91a7571182926083c087f42e7f1b3c056425d (diff)
downloadaur-3ed188b53f09c58172411a43cdb67cca7068a4ca.tar.gz
PKGBUILD: Adding MIT license. Properly quoting variables.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6598b7c2f432..dfda6ac94e5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 17 12:05:08 UTC 2017
+# Tue Oct 24 23:32:49 UTC 2017
pkgbase = prosody-mod-admin-message-hg
pkgdesc = A console over XMPP. All the commands of the mod_admin_telnet module are available from an XMPP client.
- pkgver = r2799.db0f654b9b3f
+ pkgver = r2808.2cc02ee82e8c
pkgrel = 1
url = https://modules.prosody.im/mod_admin_message.html
arch = any
@@ -10,7 +10,7 @@ pkgbase = prosody-mod-admin-message-hg
makedepends = mercurial
depends = prosody
source = hg+https://hg.prosody.im/prosody-modules/
- sha1sums = SKIP
+ sha512sums = SKIP
pkgname = prosody-mod-admin-message-hg
diff --git a/PKGBUILD b/PKGBUILD
index 456aa1c38a16..a135e873e518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: David Runge <dave@sleepmap.de>
+_pkg=prosody-mod-admin-message
pkgname=prosody-mod-admin-message-hg
-pkgver=r2799.db0f654b9b3f
+pkgver=r2808.2cc02ee82e8c
pkgrel=1
pkgdesc="A console over XMPP. All the commands of the mod_admin_telnet module are available from an XMPP client."
arch=('any')
@@ -9,7 +10,7 @@ license=('MIT')
depends=('prosody')
makedepends=('mercurial')
source=("hg+https://hg.prosody.im/prosody-modules/")
-sha1sums=('SKIP')
+sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/prosody-modules/"
@@ -17,7 +18,9 @@ pkgver() {
}
package() {
+ cd "prosody-modules"
+ install -Dm 0644 COPYING "${pkgdir}/usr/share/licenses/${_pkg}/LICENSE"
cd "${srcdir}/prosody-modules/mod_admin_message/"
- install -Dm 644 mod_admin_message.lua "${pkgdir}/usr/lib/prosody/modules/mod_admin_message.lua"
- install -Dm 644 README.markdown "${pkgdir}/usr/share/doc/prosody-mod-admin-message/README.markdown"
+ install -Dm 0644 mod_admin_message.lua "${pkgdir}/usr/lib/prosody/modules/mod_admin_message.lua"
+ install -Dm 0644 README.markdown "${pkgdir}/usr/share/doc/${_pkg}/README.md"
}