summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-01-26 11:44:26 +0100
committerDavid Runge2017-01-26 11:44:26 +0100
commit79ea092f4cc2f08175c06d2f38c5f88ff69e6672 (patch)
tree1f5e33458742b922c62163f1a9f7da5ba4d86569
downloadaur-79ea092f4cc2f08175c06d2f38c5f88ff69e6672.tar.gz
PKGBUILD: Adding first version of prosody-mod-admin-message-hg.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32ee9a47d764
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Jan 26 10:36:46 UTC 2017
+pkgbase = prosody-mod-admin-message-hg
+ pkgdesc = A console over XMPP. All the commands of the mod_admin_telnet module are available from an XMPP client.
+ pkgver = r2463.e2d955f6167f
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_admin_message.html
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = prosody
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-admin-message-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..483eb171cff4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: David Runge <dave@sleepmap.de>
+pkgname=prosody-mod-admin-message-hg
+pkgver=r2463.e2d955f6167f
+pkgrel=1
+pkgdesc="A console over XMPP. All the commands of the mod_admin_telnet module are available from an XMPP client."
+arch=('any')
+url="https://modules.prosody.im/mod_admin_message.html"
+license=('MIT')
+depends=('prosody')
+makedepends=('mercurial')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_admin_message/"
+ install -Dm 644 mod_admin_message.lua "${pkgdir}/usr/lib/prosody/modules/mod_admin_message.lua"
+ install -Dm 644 README.markdown "${pkgdir}/usr/share/doc/prosody-mod-admin-message/README.markdown"
+}