summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY2017-05-14 17:24:03 +0200
committerY2017-05-14 17:24:03 +0200
commite1d7a44d921eb0b953a0948ff8222151c45685b5 (patch)
treed625cc4556e1d297da7663f97ae18bf19c4464d4
downloadaur-e1d7a44d921eb0b953a0948ff8222151c45685b5.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac3655e964e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun May 14 15:23:19 UTC 2017
+pkgbase = prosody-mod-filter-chatstates-hg
+ pkgdesc = Client State Indication module to filter chat states depending on the client state
+ pkgver = tip
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_filter_chatstates.html
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = prosody>=0.9
+ depends = prosody-mod-csi-hg
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-filter-chatstates-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0c69ea347d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yves G. <theYinYeti@yalis.fr>
+
+pkgname=prosody-mod-filter-chatstates-hg
+pkgver=tip
+pkgrel=1
+pkgdesc="Client State Indication module to filter chat states depending on the client state"
+arch=('any')
+url="https://modules.prosody.im/mod_filter_chatstates.html"
+license=('MIT')
+depends=('prosody>=0.9' 'prosody-mod-csi-hg')
+makedepends=('mercurial')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_filter_chatstates"
+ find . -type f -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/lib/prosody/modules/{}" \;
+ find . -type f ! -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/share/doc/${pkgname}/{}" \;
+}