summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY2017-05-15 19:32:50 +0200
committerY2017-05-15 19:59:21 +0200
commitd9420286e8663dc0e7bcf493be2826f64191d6cf (patch)
tree8cfb67a7a1df3bff764fe76970032eca206bc7b2
downloadaur-d9420286e8663dc0e7bcf493be2826f64191d6cf.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf1f27dbeb00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon May 15 17:59:12 UTC 2017
+pkgbase = prosody-mod-lib-ldap-hg
+ pkgdesc = LDAP helper for other Prosody modules
+ pkgver = tip
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_lib_ldap.html
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = prosody
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-lib-ldap-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a0233bc882
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yves G. <theYinYeti@yalis.fr>
+
+pkgname=prosody-mod-lib-ldap-hg
+pkgver=tip
+pkgrel=1
+pkgdesc="LDAP helper for other Prosody modules"
+arch=('any')
+url="https://modules.prosody.im/mod_lib_ldap.html"
+license=('MIT')
+depends=('prosody')
+makedepends=('mercurial')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_lib_ldap"
+ find . -maxdepth 1 -type f -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/lib/prosody/modules/{}" \;
+ find . -maxdepth 2 -type f ! -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/share/doc/${pkgname}/{}" \;
+ find dev -maxdepth 1 -type f -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/share/doc/${pkgname}/{}" \;
+}