summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralzeih2017-10-03 15:04:08 +1300
committeralzeih2017-10-03 15:05:03 +1300
commita1f7950cdf84e7acbfbb303cf5a15b5deb1ede42 (patch)
treecd2b17d39a8ee8205e22f8986dd12dd062967194
downloadaur-a1f7950cdf84e7acbfbb303cf5a15b5deb1ede42.tar.gz
Initial Commit
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6eeb3ab37e60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = prosody-modules-hg
+ pkgdesc = prosody modules
+ pkgver = r2779.c53cc1ae4788
+ pkgrel = 1
+ url = https://modules.prosody.im/
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ makedepends = wget
+ depends = prosody
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha512sums = SKIP
+
+pkgname = prosody-modules-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3307c229a032
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: alzeih <alzeih@users.noreply.github.com>
+pkgname=prosody-modules-hg
+pkgver=r2779.c53cc1ae4788
+pkgrel=1
+pkgdesc="prosody modules"
+arch=('any')
+url="https://modules.prosody.im/"
+license=('MIT')
+depends=('prosody')
+makedepends=('mercurial' 'wget')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd "${srcdir}/prosody-modules/mod_admin_web/admin_web"
+ ./get_deps.sh
+}
+
+package() {
+ cd "${srcdir}/prosody-modules"
+ install -dm 755 "${pkgdir}/usr/lib/prosody/modules/"
+ find . -maxdepth 1 -type d -iname "mod_*" -exec cp -r "{}" "${pkgdir}/usr/lib/prosody/modules/" \;
+}