summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-19 03:58:44 +0300
committerDimitris Kiziridis2020-07-19 03:58:44 +0300
commit8710c762bb13ff38b64c14a20b7edc58be9cbc97 (patch)
treeeb23434f3159ad07ac532e77423301ff24863dff
downloadaur-8710c762bb13ff38b64c14a20b7edc58be9cbc97.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5a8c12ae3f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = prosopopee
+ pkgdesc = A static website generator to make beautiful customizable pictures galleries that tell a story
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/Psycojoker/prosopopee
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-jinja
+ depends = python-path
+ depends = python-docopt
+ depends = python-ruamel-yaml
+ depends = python-future
+ depends = python-pillow
+ conflicts = prosopopee-git
+ source = prosopopee-1.0.1.tar.gz::https://github.com/Psycojoker/prosopopee/archive/1.0.1.tar.gz
+ sha256sums = f0e46b200cddb37ac3890f8ae8293e2f59583ada2fe646d9e42138a49fab558c
+
+pkgname = prosopopee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..409be19ff168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=prosopopee
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='A static website generator to make beautiful customizable pictures galleries that tell a story'
+arch=('any')
+url='https://github.com/Psycojoker/prosopopee'
+license=('GPL3')
+conflicts=('prosopopee-git')
+depends=('python-jinja'
+ 'python-path'
+ 'python-docopt'
+ 'python-ruamel-yaml'
+ 'python-future'
+ 'python-pillow')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Psycojoker/prosopopee/archive/${pkgver}.tar.gz")
+sha256sums=('f0e46b200cddb37ac3890f8ae8293e2f59583ada2fe646d9e42138a49fab558c')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file