summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:44:25 +0200
committersmls2015-07-09 16:44:25 +0200
commit16e79f69becfa4ff52035f49dc0fcb8ee65facdc (patch)
tree9117dde6c2823150ff87130559d19d52075fb9d8
downloadaur-16e79f69becfa4ff52035f49dc0fcb8ee65facdc.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--proteus-hib.desktop10
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2029538c1e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = proteus-hib
+ pkgdesc = An audio-visual exploration game (Humble Bundle version)
+ pkgver = 1.2+h20140516
+ pkgrel = 1
+ url = http://www.visitproteus.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = glu
+ depends = alsa-lib
+ depends = libogg
+ depends = libvorbis
+ options = !strip
+ options = !upx
+ source = hib://proteus-05162014-bin
+ source = proteus-hib.desktop
+ md5sums = 8a5911751382bcfb91483f52f781e283
+ md5sums = 4ddd7b894b490e3bbd32a83922e111b3
+
+pkgname = proteus-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c0c6a8c0064
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=proteus-hib
+pkgver=1.2+h20140516
+_hibver=05162014
+pkgrel=1
+pkgdesc='An audio-visual exploration game (Humble Bundle version)'
+url='http://www.visitproteus.com/'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'glu' 'alsa-lib' 'libogg' 'libvorbis')
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar.gz'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://proteus-${_hibver}-bin"
+ 'proteus-hib.desktop')
+md5sums=('8a5911751382bcfb91483f52f781e283'
+ '4ddd7b894b490e3bbd32a83922e111b3')
+
+package() {
+ cd "$srcdir"
+ _target="/opt/Proteus"
+ [ $CARCH == i686 ] && { _lib=lib ; _other=lib64 ; _arch=x86 ;} \
+ || { _lib=lib64 ; _other=lib ; _arch=x86_64 ;}
+
+ # Install game files
+ mkdir -p "$pkgdir"/$_target
+ cp -Tal data "$pkgdir"/$_target
+
+ # Remove bundled libraries (use distro versions instead)
+ ( cd "$pkgdir"/$_target/$_lib
+ rm -r libSDL2-2.0.so.0 libSDL2_image-2.0.so.0 libSDL2_mixer-2.0.so.0 \
+ libvorbis.so.0 libvorbisfile.so.3 libogg.so.0 ../$_other )
+
+ # Install desktop entry
+ install -Dm644 "$pkgname".desktop \
+ "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ # Install icon
+ install -Dm644 data/Proteus.png "$pkgdir"/usr/share/pixmaps/proteus.png
+
+ # Install launch script
+ echo -e "#!/bin/sh\ncd $_target && ./Proteus.bin.$_arch" > launcher.sh
+ install -Dm755 launcher.sh "$pkgdir/usr/bin/proteus"
+}
diff --git a/proteus-hib.desktop b/proteus-hib.desktop
new file mode 100644
index 000000000000..9019ac225cc6
--- /dev/null
+++ b/proteus-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Proteus
+Comment=Ed Key & David Kanaga
+GenericName=Exploration Game
+Icon=proteus
+Exec=/usr/bin/proteus
+Terminal=false