summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorForud2019-10-25 11:01:21 +0200
committerForud2019-10-25 11:01:21 +0200
commita09f290acd9eab8a1fca232233934f4932a24e6b (patch)
treefae730ec9334c171f43fb851258ae8eec944abfb
parentb5c5c45abb278588fe009606d58050173dbf4163 (diff)
downloadaur-a09f290acd9eab8a1fca232233934f4932a24e6b.tar.gz
use the tar ball not the git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baea47215850..fe97bc350d93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = protobuf-go
pkgdesc = Go support for Google's protocol buffers
pkgver = 1.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/golang/protobuf
arch = i686
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = protobuf-go
makedepends = go
makedepends = git
depends = protobuf
- source = git://github.com/golang/protobuf.git
- sha1sums = SKIP
+ source = https://github.com/golang/protobuf/archive/v1.3.2.tar.gz
+ sha256sums = c9cda622857a17cf0877c5ba76688a931883e505f40744c9495638b6e3da1f65
pkgname = protobuf-go
diff --git a/PKGBUILD b/PKGBUILD
index ef0447989a12..3a0f78196a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,20 @@
# Maintainer: fzerorubigd <fzero@rubi.gd>
pkgname=protobuf-go
pkgver=1.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Go support for Google's protocol buffers"
arch=('i686' 'x86_64' 'armv5tel' 'armv6l' 'armv71')
url="https://github.com/golang/protobuf"
license=('BSD')
depends=('protobuf')
makedepends=('go' 'git')
-source=('git://github.com/golang/protobuf.git')
-
-sha1sums=('SKIP')
+source=("https://github.com/golang/protobuf/archive/v${pkgver}.tar.gz")
_gitname=protobuf
build() {
- mkdir -p ${srcdir}/src/github.com/golang/protobuf
- cd "${srcdir}/${_gitname}"
- git --work-tree=${srcdir}/src/github.com/golang/protobuf checkout -f v${pkgver}
+ mkdir -p ${srcdir}/src/github.com/golang/
+ cp -r ${srcdir}/protobuf-${pkgver} ${srcdir}/src/github.com/golang/protobuf
cd ${srcdir}/src/github.com/golang/protobuf
GOPATH=${srcdir} go get -v ./...
}
@@ -26,3 +23,5 @@ package() {
mkdir -p $pkgdir/usr/bin
install -m755 $srcdir/bin/protoc-gen-go $pkgdir/usr/bin/protoc-gen-go
}
+
+sha256sums=('c9cda622857a17cf0877c5ba76688a931883e505f40744c9495638b6e3da1f65')