summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-10-01 23:28:32 +0300
committerChristoph Gysin2017-10-01 23:30:27 +0300
commit11a5fbb0e919bbac93016193b0c502fa4342e8b0 (patch)
tree7a92ee9045cc1ab3ed7527aaa3b96c5a828fc3dd
parenta4d58eeab3fd3fc966ceea94674219a35e62ae0a (diff)
downloadaur-11a5fbb0e919bbac93016193b0c502fa4342e8b0.tar.gz
quote variables
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f9d811139bd..c138e0c0f19e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,16 +14,16 @@ source=($pkgname::git+https://github.com/stepancheg/rust-protobuf.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd "$pkgname"
echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
}
build() {
- cd $pkgname
+ cd "$pkgname"
cargo build --release
}
package() {
- cd $pkgname
+ cd "$pkgname"
install -D -m755 "$srcdir/$pkgname/target/release/protoc-gen-rust" "$pkgdir/usr/bin/protoc-gen-rust"
}