summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordavvore332018-02-09 15:33:18 +0100
committerdavvore332018-02-09 15:33:18 +0100
commitc5a0611eb0c4d8629da79912a01d49c72fda32f2 (patch)
tree17cbc9d63e4631964c7a1b7057612645eca9fb6c
downloadaur-c5a0611eb0c4d8629da79912a01d49c72fda32f2.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f5995fae5fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 9 14:29:48 UTC 2018
+pkgbase = protobuf-c
+ pkgdesc = Protocol Buffers implementation in C
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/protobuf-c/protobuf-c
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = protobuf2
+ provides = libprotobuf-c.so=1.2.1
+ conflicts = protobuf-c
+ source = https://github.com/protobuf-c/protobuf-c/releases/download/v1.2.1/protobuf-c-1.2.1.tar.gz
+ md5sums = e544249c329391fff512c3874895cfbe
+
+pkgname = protobuf-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c93f8487ed04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Matteo Triggiani <davvore33@gmail.com>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Aurélien Wailly <aurelien.wailly@gmail.com>
+
+pkgname=protobuf-c
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='Protocol Buffers implementation in C'
+arch=('i686' 'x86_64')
+url='https://github.com/protobuf-c/protobuf-c'
+license=('BSD')
+depends=('protobuf2')
+conflicts=('protobuf-c')
+provides=("libprotobuf-c.so=$pkgver")
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('e544249c329391fff512c3874895cfbe')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ make -C "$pkgname-$pkgver" check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}