summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkXuan2018-10-31 17:53:44 +0800
committerkXuan2018-10-31 17:53:44 +0800
commit8987b50bc071cb82e0f58a5deb5df20ff5712a36 (patch)
tree012d16466e4307830ebd3ff3801e37fb59cdba92
downloadaur-8987b50bc071cb82e0f58a5deb5df20ff5712a36.tar.gz
Initial commit
Signed-off-by: kXuan <kxuanobj@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9e73713e968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = protoc-gen-grpc-web
+ pkgdesc = Protobuf gRPC compiler for Web Clients
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/grpc/grpc-web
+ arch = x86_64
+ license = Apache2
+ depends = protobuf>=3
+ source = https://github.com/grpc/grpc-web/archive/1.0.0.tar.gz
+ sha512sums = affce591d5c6dfb4858ad7d6bcc8c7cfadea1d39a4f2878394e962b2bf39abe5c1f5bb1fa244a8675f1a2c717773187692e9a86ebd33196e2889fbd76e5a317f
+
+pkgname = protoc-gen-grpc-web
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0348e3f0425d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: kXuan <kxuanobj at gmail dot com>
+
+pkgname=protoc-gen-grpc-web
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Protobuf gRPC compiler for Web Clients'
+arch=('x86_64')
+url='https://github.com/grpc/grpc-web'
+license=('Apache2')
+depends=('protobuf>=3')
+source=("https://github.com/grpc/grpc-web/archive/${pkgver}.tar.gz")
+sha512sums=('affce591d5c6dfb4858ad7d6bcc8c7cfadea1d39a4f2878394e962b2bf39abe5c1f5bb1fa244a8675f1a2c717773187692e9a86ebd33196e2889fbd76e5a317f')
+
+build() {
+ cd "grpc-web-${pkgver}"
+ make plugin
+}
+
+package() {
+ cd "grpc-web-${pkgver}"
+ install -Dm755 javascript/net/grpc/web/protoc-gen-grpc-web ${pkgdir}/usr/bin/protoc-gen-grpc-web
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+