summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkXuan2022-01-29 22:26:41 +0800
committerkXuan2022-01-29 22:26:41 +0800
commitaba07588ca96c29e31ae4a38198220692cba4896 (patch)
tree17b86099203de161ad4cd4ffb69490480ccccdab
parentf146d78879c144c576426ab8f5db89491d1ac28a (diff)
downloadaur-aba07588ca96c29e31ae4a38198220692cba4896.tar.gz
bump to 1.3.1
Signed-off-by: kXuan <kxuanobj@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--0001-remove-harmful-static-flag.patch32
-rw-r--r--PKGBUILD13
3 files changed, 47 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06198ab88502..aa68395deb94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = protoc-gen-grpc-web
pkgdesc = Protobuf gRPC compiler for Web Clients
- pkgver = 1.3.0
+ pkgver = 1.3.1
pkgrel = 0
url = https://github.com/grpc/grpc-web
arch = x86_64
license = Apache2
depends = protobuf>=3
- source = https://github.com/grpc/grpc-web/archive/1.3.0.tar.gz
- sha512sums = 8023d32550df88d3cdd510211bcb58afc8c002e131f0d30720a7e8783e388709ebcf84277be255e3292578d8d93d0f6c5d6d3e062ac2eb2ae0d0a31eb201df8e
+ source = https://github.com/grpc/grpc-web/archive/1.3.1.tar.gz
+ source = 0001-remove-harmful-static-flag.patch
+ sha512sums = 1034b46107b4b528d0983be4fadae26e645fbeb5d15c0024dbb460d1a3258dc84f6181a06c81e55ab3032edd83b744c2f4b12a4882ea4f915db80d1c264453c2
+ sha512sums = 8318175b047a74ee4b5ff51739bbe9cc83f86e842221f53d502d9287154fc28d03ae682922e399e2a8b38dc26ab016d61d1e2ac868f71d2e265e28aaf3c58d49
pkgname = protoc-gen-grpc-web
diff --git a/0001-remove-harmful-static-flag.patch b/0001-remove-harmful-static-flag.patch
new file mode 100644
index 000000000000..44b93ea169f5
--- /dev/null
+++ b/0001-remove-harmful-static-flag.patch
@@ -0,0 +1,32 @@
+From 8feeb73427c7eaf075c587c856fe6f445422a897 Mon Sep 17 00:00:00 2001
+From: kXuan <kxuanobj@gmail.com>
+Date: Sat, 29 Jan 2022 22:19:46 +0800
+Subject: [PATCH] remove harmful -static flag
+
+The "-static" force g++ use static lib. But there is no static lib in the
+protobuf package.
+
+Signed-off-by: kXuan <kxuanobj@gmail.com>
+---
+ javascript/net/grpc/web/generator/Makefile | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/javascript/net/grpc/web/generator/Makefile b/javascript/net/grpc/web/generator/Makefile
+index 2c30389..3cdc1e1 100644
+--- a/javascript/net/grpc/web/generator/Makefile
++++ b/javascript/net/grpc/web/generator/Makefile
+@@ -20,11 +20,6 @@ PREFIX ?= /usr/local
+ MIN_MACOS_VERSION := 10.7 # Supports OS X Lion
+
+ UNAME_S := $(shell uname -s)
+-ifeq ($(UNAME_S),Darwin)
+- CXXFLAGS += -stdlib=libc++ -mmacosx-version-min=$(MIN_MACOS_VERSION)
+-else ifeq ($(UNAME_S),Linux)
+- LDFLAGS += -static
+-endif
+
+ all: protoc-gen-grpc-web
+
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 962f4b358d4e..8b141413e1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,22 @@
# Maintainer: kXuan <kxuanobj at gmail dot com>
pkgname=protoc-gen-grpc-web
-pkgver=1.3.0
+pkgver=1.3.1
pkgrel=0
pkgdesc='Protobuf gRPC compiler for Web Clients'
arch=('x86_64')
url='https://github.com/grpc/grpc-web'
license=('Apache2')
depends=('protobuf>=3')
-source=("https://github.com/grpc/grpc-web/archive/${pkgver}.tar.gz")
-sha512sums=('8023d32550df88d3cdd510211bcb58afc8c002e131f0d30720a7e8783e388709ebcf84277be255e3292578d8d93d0f6c5d6d3e062ac2eb2ae0d0a31eb201df8e')
+source=("https://github.com/grpc/grpc-web/archive/${pkgver}.tar.gz" "0001-remove-harmful-static-flag.patch")
+sha512sums=('1034b46107b4b528d0983be4fadae26e645fbeb5d15c0024dbb460d1a3258dc84f6181a06c81e55ab3032edd83b744c2f4b12a4882ea4f915db80d1c264453c2'
+ '8318175b047a74ee4b5ff51739bbe9cc83f86e842221f53d502d9287154fc28d03ae682922e399e2a8b38dc26ab016d61d1e2ac868f71d2e265e28aaf3c58d49')
+
+prepare() {
+ for i in *.patch; do
+ patch -p1 -d "grpc-web-${pkgver}" <"$i"
+ done
+}
build() {
cd "grpc-web-${pkgver}"