summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWayne Hartmann2015-09-21 03:19:30 -0500
committerWayne Hartmann2015-09-21 03:19:30 -0500
commitff86a8940c629c4cfcf72c07b4ad202c02cde0c5 (patch)
treecdb86d6202de4c5782075e941125e47eac82e2bf
downloadaur-ff86a8940c629c4cfcf72c07b4ad202c02cde0c5.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--ProtocaseDesigner.desktop10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0521639740e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = protocase-designer
+ pkgdesc = The fastest and easiest way to design, price, and build custom electronics enclosures.
+ pkgver = 4.4.8
+ pkgrel = 1
+ url = http://www.protocasedesigner.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime-common
+ depends = jre7-openjdk
+ source = http://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-i586-4.4.8.tar.gz
+ source = ProtocaseDesigner.desktop
+ md5sums = 5f313ca4e923136f75a6b4cb0deba678
+ md5sums = f66d02094444eac61f468371589fcc9c
+
+pkgname = protocase-designer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebee30df344f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Wayne Hartmann (DH4) <wayne@bitstorm.pw>
+
+pkgname=protocase-designer
+pkgver=4.4.8
+pkgrel=1
+
+pkgdesc="The fastest and easiest way to design, price, and build custom electronics enclosures."
+arch=('i686' 'x86_64')
+url="http://www.protocasedesigner.com/"
+depends=('java-runtime-common' 'jre7-openjdk')
+#install=protocase-designer.install
+license=('custom')
+source=(http://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-i586-4.4.8.tar.gz
+ ProtocaseDesigner.desktop)
+md5sums=('5f313ca4e923136f75a6b4cb0deba678'
+ 'f66d02094444eac61f468371589fcc9c')
+
+[ "$CARCH" = "x86_64" ] && source=(http://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-amd64-4.4.8.tar.gz
+ ProtocaseDesigner.desktop)
+[ "$CARCH" = "x86_64" ] && md5sums=('488d5ef878132acbabba6e9fc77c72bc'
+ 'f66d02094444eac61f468371589fcc9c')
+
+package() {
+
+ install -d $pkgdir/usr/local/lib/
+ cp -R $srcdir/jdesigner/Protocase\ Designer $pkgdir/usr/local/lib
+ install -d $pkgdir/usr/local/share/Protocase\ Designer/
+ cp -R $srcdir/jdesigner/library $pkgdir/usr/local/share/Protocase\ Designer/
+ install -d $pkgdir/usr/local/share/pixmaps/
+ cp $srcdir/jdesigner/Protocase\ Designer.ico $pkgdir/usr/local/share/pixmaps/ProtocaseDesigner.ico
+
+ install -d $pkgdir/usr/local/bin/
+ echo '#/bin/sh' > $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "install -d ~/ProtocaseDesigner/" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "mkdir ~/ProtocaseDesigner/UserLibrary" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "LD_LIBRARY_PATH=/usr/local/lib/Protocase\ Designer/:/usr/local/lib/Protocase\ Designer/lib/:\ $LD_LIBRARY_PATH java -jar /usr/local/lib/Protocase\ Designer/jdesigner.jar >> ~/ProtocaseDesigner/error.log 2>&1" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ chmod 755 $pkgdir/usr/local/bin/ProtocaseDesigner
+
+ install -d $pkgdir/usr/local/share/applications/
+ cp $srcdir/ProtocaseDesigner.desktop $pkgdir/usr/local/share/applications/ProtocaseDesigner.desktop
+}
diff --git a/ProtocaseDesigner.desktop b/ProtocaseDesigner.desktop
new file mode 100644
index 000000000000..5002ada036f3
--- /dev/null
+++ b/ProtocaseDesigner.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Protocase Designer
+Comment=The fastest and easiest way to design, price, and build custom electronics enclosures.
+Exec=/usr/local/bin/ProtocaseDesigner
+Icon=/usr/local/share/pixmaps/ProtocaseDesigner.ico
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=